Haberler

Gönderen Konu: Ağ Arayüzlerindeki İsimlendirmeler (eth0, wlan0 vs)  (Okunma sayısı 3659 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı GNU

  • İleti: 104
Bildiğiniz gibi son zamanlarda ağ ara yüzlerinde bazı tanım ve isim değişiklikleri baş göstermeye başladı ve bu bazılarımızın arch kurulumunda ve sonrasında kablosuz ağa bağlanmasında bile sorun teşkil etti. Aslında bu bir sorun olmamakla birlikte eth0 veya wlan0 tanımlarının durduk yerde enp5s0 gibi bir tanıma dönüşmesini istemiyorsak çözüm çok basit.
Kod: [Seç]
ln -s /dev/null /etc/udev/rules.d/80-net-name-slot.rules

komutu ile eski isimlendirmeleri kullanmaya devam edebiliriz.



Kendim komutu uyguladım ve sonuç:
Kod: [Seç]

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.2.223  netmask 255.255.255.0  broadcast 192.168.2.255
        ether 00:16:d3:4b:fd:73  txqueuelen 1000  (Ethernet)
        RX packets 7053778  bytes 8203528220 (7.6 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4670728  bytes 429175291 (409.2 MiB)
        TX errors 0  dropped 1 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 0  (Local Loopback)
        RX packets 466  bytes 34668 (33.8 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 466  bytes 34668 (33.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:21:63:38:e1:85  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Gördüğünüz üzere eth0 ve wlan0 aynı kaldı.



KAYNAK: Freedesktop...
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı cumali

  • Administrator
  • *****
  • İleti: 2.228
Yanıtla #1 : 20 Şubat 2013 - 21:20:31
Paylaşım ve bilgilendirme için teşekkür ederim @korokos.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı hsngrms

  • İleti: 1.707
Yanıtla #2 : 21 Şubat 2013 - 18:27:44
Teşekkürler. Bende dosyanın içeriğinde önemli bir şey yokmuş. Zaten hep wlan0 idi :)
Kod: [Seç]
# This file masks persistent renaming rules for network devices. If you
# delete this file, /usr/lib/udev/rules.d/80-net-name-slot.rules may
# rename network devices according to ID_NET_NAME_{ONBOARD,SLOT,PATH}
# properties of your network devices, with priority in that order. See
# the output of 'udevadm test-builtin /sys/class/net/$interface' for
# details on what that new name might be.
#
# http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı agritux

  • İleti: 35
Yanıtla #3 : 21 Şubat 2013 - 22:36:00
Çok teşekkür ederim. İşe yaradı. Ben netcfg ile bağlanmak zorunda kalıyordum. Ağ arayüzümdeki isim wlp2s0 olduğu için. Network managerde ayarlayamamıştım. hsngrms sağolsun hallettik.



Yalnız şimdi şöyle bir durum var.

eskiden wifi-menu wlp2s0 ile bağlanıyordum şimdi sadece wifi-menu yiyor.

iwconfig çıktısında da wlan0 görünüyor. buraya kadar tamam.



systemctl den netcfg yi kaldırdım. NetworkManager i koydum. network-manager-appleti kurdum. sistemi yeniden başlattım. ama halen bağlanamıyorum :)
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı cumali

  • Administrator
  • *****
  • İleti: 2.228
Yanıtla #4 : 21 Şubat 2013 - 22:53:56
Networkmanager paketini kurduysan başlangıçta aktif olması için
Kod: [Seç]
#systemctl enable NetworkManager.service

komutunu uyguladınmı?
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı agritux

  • İleti: 35
Yanıtla #5 : 21 Şubat 2013 - 22:59:03
Evet tabiki.

şimdi wikiye bakıyordum. dhcpcd gibi bir şeyi aktive etmem gerekmiyor değil mi?
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı cumali

  • Administrator
  • *****
  • İleti: 2.228
Yanıtla #6 : 21 Şubat 2013 - 23:20:51
Kablosuz bağlantı kullandığından gerek yok.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı GNU

  • İleti: 104
Yanıtla #7 : 21 Şubat 2013 - 23:25:36
agritux, gnome-keyring kurmanı şiddetle tavsiye ederim.
« Son Düzenleme: 21 Şubat 2013 - 23:30:30 Gönderen: GNU »



Çevrimdışı agritux

  • İleti: 35
Yanıtla #8 : 21 Şubat 2013 - 23:29:26
Cevaplar için teşekkürler.

Bir şekilde şimdi bağlanabildim. Ama şöyle bir durum var. network-manager-applet paketini kurmama rağmen, sistem çekmecesinde wifi simgesine tıklayıp ağ ayarlarını seçtiğimde hiç bir şey olmuyor. Network-manager-applet açılmıyor.



Cinnamon menüden bulup çalıştırdığımda, çalışıyor, ağı görüyor, bağlı olduğunu gösteriyor applet. Ama düzenle deyip bir statik ip atamam, sistemi etkilemiyor. Ya da dns değiştirmem sistemi etkilemiyor.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı cumali

  • Administrator
  • *****
  • İleti: 2.228
Yanıtla #9 : 21 Şubat 2013 - 23:43:17
Bilindigi gibi Dns ayarı için /etc/resolv.conf dosyasını düzenleyebiliyoruz. Uçbirimden root olarak
Kod: [Seç]
#nano /etc/resolv.conf

komutunu uygulayın. Dilediginiz dnsyi girin. Kaydedip kapatın. Hepsi bu. Örnegin; google dns için
Kod: [Seç]
# Generated by resolvconf
nameserver 8.8.8.8
nameserver 8.8.4.4

olabilir. Kimsenin degiştirmesini istemiyorsanız
Kod: [Seç]
chattr +a /etc/resolv.conf

komutunu uygulayın
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı agritux

  • İleti: 35
Yanıtla #10 : 22 Şubat 2013 - 00:24:44
@cumali, teşekkürler.

Fakat benim için gui biraz önemli. Bilgisayarın birden fazla kullanıcısı var.

Evde iken, netcfg nin sıkıntı yaratmayacağını düşünmüştüm. Gayet güzel geçiniyorduk. Ama bugün kardeşim okula götürmüş bilgisayarı. Sunum yapmak için. İnternete bağlanıp mail adresinden sunumu almak istediğinde alamamış. Çünkü netcfg kullanmayı bilmiyor. Linuxden uzak. Onun için arayüz olsun istiyorum. Acaba neden ayarları değiştirmiyor. Simgesiyle çalışmıyor. Umarım bulurum :)
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı cumali

  • Administrator
  • *****
  • İleti: 2.228
Yanıtla #11 : 22 Şubat 2013 - 09:28:48
@agritux, sanırım bazı uygulamalar eksik. Şu an Cinnamon ortamındayım. Bende herşey gayet güzel gidiyor. Önerim önce pamac paket yöneticisini yükleyin. http://archtr.org/forum/viewtopic.php?f=13&t=837&p=8040&hilit=pamac#p7937" class="bbc_link" target="_blank">http://http://archtr.org/forum/viewtopic.php?f=13&t=837&p=8040&hilit=pamac#p7937 Şöyle karşınıza alıp konu ile ilgili hangi paketlerin yüklü olup olmadığını gözlemleyin. Mesela network-manager-applet ayrı, networkmanager ayrı uygulamalar.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı ekber

  • İleti: 112
Yanıtla #12 : 04 Mart 2013 - 00:16:54
selam,



wpa_supplicant paketini de kurdunmu? wpa-psk sifreleme kullandigin zaman


Kod: [Seç]
wpa_passphrase  SSID  Passwort  > /etc/wpa_supplicant/wpa_supplicant.conf
wpa_supplicant -i wlan0 -D wext -c /etc/wpa_supplicant/wpa_supplicant.conf -B
dhcpcd wlan0

uyguluyorsun ve
Kod: [Seç]

cd /etc/network.d/examples

 cp wireless-wpa /etc/network.d/
 cd ..
 nano wireless-wpa
girip essid ve passwort ekleme yaptiktan sonra


Kod: [Seç]
systemctl enable netcfg@wireless-wpa (wireless-wpa kendi istedigin isimi ile deyistirip de aktif edebilirsin)

systemctl start netcfg@wireless-wpa


ben kendim net-profile yöntemi kullaniyorum ve sakli essid ile simdiye kadar sorunsuz baglaniyor ;)



nm-applet (networkmanager) ile islemci durmadan calisiyordu ve netcfg ile daha sakindi, ama systemd süresi uzuyor, olsun deyer ama ;)
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Alamanyadan Selamlar :)