Haberler

Gönderen Konu: [Çözüldü]RTL8111 wifi sorunu  (Okunma sayısı 6926 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı agritux

  • İleti: 35
: 09 Şubat 2013 - 01:37:40
Kod: [Seç]
[root@agritux arda]# lspci | grep -i net
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 130 (rev 34)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)


Bu benim kart ile sorun yaşayan çokmuş sanırım. Ben ilk kez arch ile yaşıyorum. Kurulum sırasında da görmemişti kablosuz ağları.. Kablolu ile bağlanıyorum bende.



Sorun şu ki, kablosuz ağları görüyor, listeliyor fakat bağlanmıyor.

Ağ adına tıkladığımda, ağ bağlantısı etkinleştirilemedi diyor.

Sürücülerin yüklü olmadığından kaynaklandığını düşünüyorum fakat ne resmi depolarda nede aur da rtl8111 için sürücü yok.



Sorun grup desem kullanıcı network gurubuna dahil.


Kod: [Seç]
[root@agritux arda]# id -G -n arda
arda wheel log network video audio optical storage power users
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »




Çevrimdışı curelight

  • İleti: 127
Yanıtla #2 : 09 Şubat 2013 - 10:13:21
Sanırım sizin kartınız için r8168 modülünü kurmanız gerekiyor.Depoda mevcut. Ayrıca lsmod çıktısında r8169 görünüyorsa eğer, yeni kuracağınız paketten sonra  rmmod r8169 şeklinde geçici olarak kaldırıp denemenizde fayda var.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı agritux

  • İleti: 35
Yanıtla #3 : 09 Şubat 2013 - 13:05:03
Saatlerdir bununla uğraşıyorum.

Sistem zaten kendi otomatikman r8169 u kurmuş. Depodan r8168 i kurup r8169 u blackliste attığımda, kablolu olarka bile bağlanamıyorum.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı curelight

  • İleti: 127
Yanıtla #4 : 09 Şubat 2013 - 14:49:55
Peki wireless_tools ve dhcpcd paketi kurulumu? Ve sanırım 8169 a geri dönmeniz gerekecek bu durumda.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı agritux

  • İleti: 35
Yanıtla #5 : 09 Şubat 2013 - 14:58:40
kurulu onlar. sistemi kurarken kurmuştum.



8168 ile iş yapamayınca 69 a geri döndüm zaten. şu an 69 dayım.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı hsngrms

  • İleti: 1.707
Yanıtla #6 : 09 Şubat 2013 - 19:07:07
@agritux ne güzel demişsin,
Alıntı
kablolu olarak bile bağlanamıyorum
niye, çünkü RTL8111 ethernet kartın zaten, onun sürücüsünü blackliste alınca bağlanmadı tabi. :)



Kablosuz ağ kartı
Alıntı
Kod: [Seç]
Intel Centrino Wireless-N 130
olduğuna göre ona göre [c]$ iwconfig[/c] çıktısına bakalım. Ayrıca
Alıntı
kablosuz ağları görüyor, listeliyor fakat bağlanmıyor
kısmını biraz açalım, hangi uygulama yardımı ile bağlanmaya çalışıyorsunuz?
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı agritux

  • İleti: 35
Yanıtla #7 : 09 Şubat 2013 - 20:46:57
hsngrms dun aksamdan beri ugrasiyorum. tam vazgecmisken yakaladiniz :)



kisaca biraz ozetleyeyim.

Arch kurulumu baslangicinda wifi-menu yazdigimda yapmasi gereken isi yapmadi. birde somurtan surat cikardi :(

bende kablolu olarak baglandim ve kurulumu tamamladim.

kurulum ardindan sistem cekmecesinde kablosuz aglari gorebiliyor. ama tikladigimda ag aktive olamadi gibi bir uyari veriyor.



yukaridaki mesajlarimin ve tonlarca ugraslarimin ardindan; sistem dosyalari ve paketleri uzerinde cok oynama yaptim. bu yuzden temiz bir kurulum yapayim dedim.



kurulum ardindan r8169 u blackliste atip r8168 i kurdum. bu sefer kablolu aga baglandim, kablosuzlari gordum ama yine baglanamadim.

tipki ilk kurulum ardindan oldugu gibi.



sizin soylediginiz gibi sonradan yanlis is yaptigimi dusundum. ve bu sefer intel kart icin calismaya basladim.

http://wireless.kernel.org/en/users/Dri ... =Downloads

adresinden

http://wireless.kernel.org/en/users/Dri ... 68.5.2.tgz

driverini indirdim

readme de yazdigi gibi ilgili dosyayi firmware klasorune kopyaladim.

yeniden baslattim

yine baglanamadim kablosuz aglara.



daha sonra aur dan kurdugum nemo ile firmware klasorune girdim

bir de baktim ki; zaten tum intel driverlari icerisinde var.



ozaman benim sorunum ne diye dusunmeye basladim.

acaba kullanici hesabini atadigim gruplarda mi sikinti var dedim

arch wiki de gruplara baktim.

networkmanager grubunu gordum

ona ekleyim dedim ama oyle bir grup yok dedi

kullanicinin atanmis oldugu gruplara baktim; network grubunda dahildi

sorun bundan da degildi



ozaman yetki gibi bir sey mi acaba dedim

saatlerce aradim arastirdim ama bir sey bulamadim.



bende vazgectim.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı agritux

  • İleti: 35
Yanıtla #8 : 09 Şubat 2013 - 20:53:28
iwconfig çıktısı:


Kod: [Seç]
[root@agritux arda]# iwconfig
wlp2s0    IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
         
lo        no wireless extensions.

enp3s0    no wireless extensions.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı hsngrms

  • İleti: 1.707
Yanıtla #9 : 09 Şubat 2013 - 22:46:44
Sürücüler vardır bu ağ kartlarında çıkan sorun tanınmamaktan ziyade yavaşlık veya bağlantı kopması olabiliyor.



Geçen kuzenime kurulum yaptım onda da N 100 veya N 130 vardı, kablosuz epey uğraştırdı ama çözümü buldum yeni bir şeyler öğrenmiş oldum. Ve bunu yeni kurulum anlatımına ekledim, en kısa sürede yayınlayacağım.



Öncelikle ağları görüp bağlanabiliyor musunuz buna bakalım, kurulum CD/USB'si ile sistemi başlatıp aşağıdaki komutu verin ve ağları görüp bağlanabiliyor musunuz söyleyin.
Kod: [Seç]
wifi-menu wlp2s0

Eğer not found hatası alırsanız wlp2s0 yerine iwconfig çıktısındaki kablosuz arayüzün adını yazın.



Bağlanamazsanız aşağıdaki komutları verin sonra tekrar deneyin.
Kod: [Seç]
ip link set dev wlp2s0 up
iwconfig wlp2s0 power on

Yine burada da wlp2s0 hata verirse iwconfig çıktısına uygun olarak değiştirin.



Dipnot: Anlatımda da wlp2s0 örneğini kullanmıştım, paylaşınca göreceksiniz. :)
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı agritux

  • İleti: 35
Yanıtla #10 : 09 Şubat 2013 - 22:49:53
Anlatımı sabırsızlıkla bekliyorum ozaman :)

peki bunu hali hazır kurulu sistemde değil de, siyah ekranda (kurulum ekranında) yapmamızın maksadı nedir?
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı agritux

  • İleti: 35
Yanıtla #11 : 09 Şubat 2013 - 22:56:48
Sürpriz;

wifi-menu wlp2s0

ile sorunsuzca bağlandım

pacman -Syy ile bağlanıp bağlanmadığını doğruladım

bağlandı



Şimdi ne olacak :)
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı cumali

  • Administrator
  • *****
  • İleti: 2.228
Yanıtla #12 : 09 Şubat 2013 - 23:05:55
Alıntı yapılan: "agritux"

Şimdi ne olacak :)


 :huh:  :huh:
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı hsngrms

  • İleti: 1.707
Yanıtla #13 : 09 Şubat 2013 - 23:17:24
Alıntı yapılan: "agritux"
Anlatımı sabırsızlıkla bekliyorum ozaman :)

peki bunu hali hazır kurulu sistemde değil de, siyah ekranda (kurulum ekranında) yapmamızın maksadı nedir?

Maksadımız temiz bir sistemde sorun yaşanıp yaşanmadığını görmek, son yaptığınız değişikliklerden sonra bozulma olma riskine karşı. :)


Alıntı yapılan: "agritux"
Sürpriz;

wifi-menu wlp2s0

ile sorunsuzca bağlandım

pacman -Syy ile bağlanıp bağlanmadığını doğruladım

bağlandı



Şimdi ne olacak :)

Kurulu sistemde bağlantı sağlayabildiyseniz her şey yolunda demektir. Eğer netcfg kullanacaksanız [c]/etc/conf.d/netcfg[/c] dosyasında kablosuz arayüzü wlp2s0 olarak değiştirin. (Varsayılan wlan0 dır) (Bunu değiştirdikten sonra wifi-menu komutunu verirken wlp2s0 diye yazmanıza gerek kalmaz.)



Ayrıca wifi-menu ile bağlandığınızda otomatik profil oluşturur. Yine [c]/etc/conf.d/netcfg[/c] dosyasında NETWORKS=(last) olarak ayarlı ise otomatik olarak bu ağa bağlanır açılışta. (last: en son bağlanan ağa bağlanması için)
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı agritux

  • İleti: 35
Yanıtla #14 : 09 Şubat 2013 - 23:21:39
/etc/conf.d/netcfg

dosyasını düzenleyip kaydettim. ardından sistemi yeniden başlattım. durum sabit. yine bağlanamadım. :(

yeniden mi kurulum yapmam gerekecek?



temiz kurulumun ardından yaptığım tek değişiklik

http://wireless.kernel.org/en/users/Dri ... 68.5.2.tgz

dosyasındaki driver i firmware klasörüne kopyalamak idi.

cd den bu driveri bulup firmware klasörüne atabilir miyim acaba

çözüm olur mu?
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı agritux

  • İleti: 35
Yanıtla #15 : 09 Şubat 2013 - 23:38:16
archtr irc den orjinal dosyayı edindim

yerine kopyalayıp yeniden başlattım sistemi

sistem çekmecesinde yine bağlanamıyorum

terminalde wifi-menu ile bağlanmayı denediğimde  

> WPA Authentication/Association Failed

diyor :(
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı imarah

  • İleti: 56
Yanıtla #16 : 09 Şubat 2013 - 23:39:19
Alıntı yapılan: "agritux"
archtr irc den orjinal dosyayı edindim

yerine kopyalayıp yeniden başlattım sistemi

sistem çekmecesinde yine bağlanamıyorum

terminalde wifi-menu ile bağlanmayı denediğimde  

> WPA Authentication/Association Failed

diyor :(


Network manager kurulu mu?
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı agritux

  • İleti: 35
Yanıtla #17 : 09 Şubat 2013 - 23:40:58
imrah, kurulu. servisi de systemctl de enabled. açılışta aktive oluyor.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı hsngrms

  • İleti: 1.707
Yanıtla #18 : 09 Şubat 2013 - 23:43:33
Netcfg ile bağlanıyorsanız bunun için profil oluşturdunuz mu? Yoksa hep wifi-menu komutunu mu kullanıyorsunuz? Bağlanmadıysa verdiği hata nedir?




[/hr]

Kablosuz ağınız için profil oluşturup deneyin;

Profili [c]/etc/network.d/[/c] dizini içerisinde oluşturacaksınız. Mesela dosyanın adı kablosuz olsun, oluşturdunuz içeriği şöyle olacak;
Kod: [Seç]
CONNECTION='wireless'
DESCRIPTION='agritux un kablosuz agi'
INTERFACE='wlp2s0'
SECURITY='wpa'
ESSID='BURAYA-AĞIN-ADINI-YAZIN'
KEY='BURAYA-AĞIN-ŞİFRESİNİ-YAZIN'
IP='dhcp'

Ağın adını ve şifreyi değiştirmeyi unutmayın. Tanımı da değiştirebilirsiniz hoşunuza gitmediyse böylesi. :)



Oluşturdunuğunuz bu profile şu komutla bağlanabilirsiniz
Kod: [Seç]
# netcfg kablosuz

kablosuz yerine kendi seçtiğiniz ismi yazın.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı cumali

  • Administrator
  • *****
  • İleti: 2.228
Yanıtla #19 : 09 Şubat 2013 - 23:44:17
Alıntı yapılan: "agritux"
imrah, kurulu. servisi de systemctl de enabled. açılışta aktive oluyor.

Şimdi anlarız. Şu çıktıyı alalım;
Kod: [Seç]
$systemctl list-unit-files | grep dm
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı agritux

  • İleti: 35
Yanıtla #20 : 09 Şubat 2013 - 23:47:21
hsngrms;

kendisi oluşturmuş

sizin tanımınızın aynı

şifre vs doğru



sistem çekmecesindeki simge üzerine tıkladığımda ağ listesi geliyor

ağı seçtiğimde hiçbirşey olmuyor

şifre bile istemiyor

direk
Alıntı
bağlantı başarısız, etkinleştirilemedi
diyor



wifi-menu ile olan sonucu yukarı yazdım.



cumali:
Kod: [Seç]
[root@agritux arda]# systemctl list-unit-files | grep dm
krb5-kadmind.service                        disabled
mdadm.service                               disabled
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı agritux

  • İleti: 35
Yanıtla #21 : 09 Şubat 2013 - 23:49:23
cumali:

komuttan grep i kaldırıp tamamına baktığımda network ile ilgili olanlar:
Kod: [Seç]

mdadm.service                               disabled
net-auto-wired.service                      disabled
net-auto-wireless.service                   disabled
net-profiles.service                        disabled
netcfg.service                              disabled
netcfg@.service                             disabled
NetworkManager-wait-online.service          disabled
NetworkManager.service                      enabled
nscd.service                                disabled
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı hsngrms

  • İleti: 1.707
Yanıtla #22 : 09 Şubat 2013 - 23:51:35
Bu çıktı iyi oldu.



@agritux, netcfg ile bağlanamıyorsun çünkü servis aktif değil.



netcfg kullanacaksan NetworkManager'ı iptal etmelisin, çakışma olursa çalışmaz.


Kod: [Seç]
systemctl disable NetworkManager
systemctl enable netcfg
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı agritux

  • İleti: 35
Yanıtla #23 : 09 Şubat 2013 - 23:58:54
network manageri disable edip netcfg yi aktive edince oldu.

:)

ama sistem çekmecesindeki simge de kayboldu.

/etc/conf.d/netcfg içerisinde network de last kendiliğinden vardı

yani son ağa kendi bağlanacak. bunu biliyorum.

peki bu netcfg için bir arayüz mevcut mu

ya da networkmanager ile bir çözümü varmı?

tekrar çok teşekkür ederim
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı cumali

  • Administrator
  • *****
  • İleti: 2.228
Yanıtla #24 : 10 Şubat 2013 - 00:00:25
Alıntı yapılan: "hsngrms"

netcfg kullanacaksan NetworkManager'ı iptal etmelisin, çakışma olursa çalışmaz.
Kod: [Seç]
systemctl disable NetworkManager
systemctl enable netcfg

He he,çıktı işe yaradı sanırım. Aynen @hsngrms'nin dedigi gibi olmalı.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »