Gönderen Konu: Son Yaşadığım Arch Deneyimi  (Okunma sayısı 417 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı GNU

  • Newbie
  • *
  • İleti: 104
Son Yaşadığım Arch Deneyimi
« : 01 Ocak 2013 - 22:22:37 »
Sizlerle son 2 gündür yaşadığım ve sonunda çözüme kavuşan Arch kurulum/güncelleme ve bug'ı hakkında bilgi vermek istiyorum. Yaşadığım sorun aslında yabancı bir forumda bahsedilenle aynı. Olay Curl'un ipv6 nedeniyle gösterdiği garip davranıştan kaynaklanıyormuş. Sorun live cd başlangıcında boot öncesi kernel satırının sonuna ipv6.disable=1 eklemekle kolayca çözüldü ancak bu kalıcı bir çözüm değil tabi zira ekleme yapmamamız gerek doğal haliyle sorunsuz çalışmak zorunda. Tabi geliştiricilerden Dave Reisner bununla ilgili bug'ı 1 yıl önce işlemiş ve konu hakkında "bu sorun yeni değil daha önce bir benzerini de wget için görmüştük ve çözümün ipv6'yı pasif hale getirerek giderilmesinden yana değilim demiş". Ne diyelim, umarım erken zamanda çözüme kavuşur, yine de pek umudum yok çünkü düşük öncelikli olarak belirlenen bir bug ve neredeyse 1 yıllık.



Neyse kurulumu tamamladıktan sonra tamamen yabancısı olduğum systemd ile işlemlere sıra geldi. Önce kurduğum nvidia nedense X ile sorun çıkardı ve modül olarak tanınmadı. Bunun üzerine nvidia'yı kaldırıp yerine açık kaynak kodlu nouveau kurdum. Bir kez reboot ettim ama bu sefer de slim başlamadı. Eskiden deamons içine eklediğimiz slim satırı şimdi servis olarak başlatılıyormuş. Onu da enable ettikten sonra xfce ortamı güzelce açıldı.



XFCE ortamında istemediklerimi kaldırıp istediklerimi kurdum ve tertemiz bir sistem elde ettim ancak bu sefer de GTK problemi baş gösterdi. Forumlarda okuduklarımın bir çoğunu uygulamama rağmen XFCE için uygun olan GTK2 tema kullanıp sistemde kurulu olan GTK3 temasını transmission, gaupol ve network manager gibi programlara bir türlü gösteremedim. Bunun üzerine ben de pes edip mecburen bir GTK3 teması (faience teması ve faenza-ambiance ikonları) ve onun ikon setini kurup sorunun üstünü örttüm.



Şimdi Xubuntu'da Arch'ta olmayan ne var ki GTK2 teması işler durumda iken diğer programlar sorunsuz gözüküyor? Bunu bir bilen varsa lütfen paylaşsın zira yabancı forumlarda bile bu konuda şunu yap kesin düzelir diyebilen birini görmedim. Kanımca bu üzerinde durulması gereken bir konu.



Herkese bol Arch'lı günler.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı cumali

  • Administrator
  • *****
  • İleti: 2.228
Re: Son Yaşadığım Arch Deneyimi
« Yanıtla #1 : 01 Ocak 2013 - 23:29:04 »
@korokos, keşke çıkması beklenen Arch Linux 2013 iso kalıbı ile kurulumu yapsaydın. Muhtemelen bir çok hatanın giderildigi bir Arch ile karşılaşırdınız. Geçtigimiz yılda Arch iso kalıbında ciddi degişiklige gidildi. Tabiri caizse taşlar yerinden oynadı. Kurulum aracının kaldırılması,systemd'e geçiş yapmış olması  vs. vs. Eski Arch kullanıcılarının bile adapte olmada sıkıntı yaşadığını biliyorum. Sorunların bir kısmını kişisel gayretlerinizle çözmüşsünüz. GTK2 tema konusununda çözülebilecegini düşünüyorum. Yalnız konu ile ilgili  Xubuntu ile Arch karşılaştırmasını doğru bulmadım.Gerekçesi ise Xubuntu yapılandırılmış bir vaziyette gelirken Arch yapılandırmayı kullanıcıya bırakmaktadır. Çözümlerini buldukça konuya ekleme yaparız.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı GNU

  • Newbie
  • *
  • İleti: 104
Re: Son Yaşadığım Arch Deneyimi
« Yanıtla #2 : 02 Ocak 2013 - 00:26:16 »
Amacım karşılaştırma yapmak değil zaten Cumali zira biri debian tabanlı ki ilk göz ağrım ondan asla vazgeçemem diğeri ise son göz ağrım ondan da vazgeçemiyorum :)



Söylemek istediğim xubuntu'da ne tür bir yapılandırma yapıldığını açıkça ortaya koyabilirsek Arch için de görsellik sorununa o kadar kalıcı çözüm bulmuş oluruz.



Bu arada Arch 2013 kalıbı ne zaman çıkıyor?
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı cumali

  • Administrator
  • *****
  • İleti: 2.228
Re: Son Yaşadığım Arch Deneyimi
« Yanıtla #3 : 02 Ocak 2013 - 00:39:19 »
Sanırım ben anlatamadım. Mesele Debian ve Arch meselesi degil. Biri yapılandırılmış vaziyette hazır gelmiş olması,digeri ise yapılandırmayı kullanıcıya bırakmış olması. Aynı şartlarda degerlendirme yapmak gerekir. Onu söylemeye çalıştım. Örnegin bana göre Manjaro Arch tabanlı bir Linux dağıtımı ve geliştiricisi yapılandırmasını çok güzel yapıyor. Ama ben Arch'ı geliştirici gibi yapılandıramıyorum. Yani istenen seviyeye gelebilmek için yeterli bilgi ve olanaklara sahip olmak gerekir diye düşünmekteyim.



Öte yandan Arch 2013 iso kalıbı her an duyurulabilir. Bugün yada yarın çıkabilir. Zira planlarında her ay bir sürüm çıkartacağı şeklinde idi.



http://www.archtr.org/2012/12/02/aralik-yeni-kurulum-ortami-zamani/" class="bbc_link" target="_blank">http://http://www.archtr.org/2012/12/02/aralik-yeni-kurulum-ortami-zamani/
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı xxx3

  • İleti: 111
Re: Son Yaşadığım Arch Deneyimi
« Yanıtla #4 : 04 Ocak 2013 - 23:20:45 »
Birşey sormak istiyorum Xfce zaten minumum şekilde kurulmuyor mu sisteme acaba neden bazı paketlerini kaldırmak istediniz.Ben sadece pacman -S xfce komutuyla kurulum yaptım ve gayet az paket kurmuştu.Bence yaşadığınız sorun kaldırdığınz bir paketten kaynaklanıyor olabilir.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı GNU

  • Newbie
  • *
  • İleti: 104
Re: Son Yaşadığım Arch Deneyimi
« Yanıtla #5 : 04 Ocak 2013 - 23:40:44 »
@xxx3 : Sorun herhangi bir DE kurmadan önce vardı, yazımın ilk paragrafında verdiğim linklere bakabilirsin. Neden bazı paketleri kaldırdığıma gelince xfce-goodies içindeki birçok plugini kullanmadığım için kaldırdım, xfce4-weather-plugin gibi paketleri.



Bu arada bir bilgiyi de vermek istiyorum. Önceki sürümlerde nvidia legacy kartlar için direkt #pacman -S nvidia ile kurulum yapıyorduk o değişmiş. Geforce 7 öncesi kartlar için
Kod: [Seç]
#pacman -S nvidia-304xx
komutuyla kurulum yapmak zorundayız yoksa nvidia modülü tanınmıyor ve X açılmıyor.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı xxx3

  • İleti: 111
Re: Son Yaşadığım Arch Deneyimi
« Yanıtla #6 : 04 Ocak 2013 - 23:49:14 »
Alıntı yapılan: "korokos"
@xxx3 : Sorun herhangi bir DE kurmadan önce vardı, yazımın ilk paragrafında verdiğim linklere bakabilirsin. Neden bazı paketleri kaldırdığıma gelince xfce-goodies içindeki birçok plugini kullanmadığım için kaldırdım, xfce4-weather-plugin gibi paketleri.



Bu arada bir bilgiyi de vermek istiyorum. Önceki sürümlerde nvidia legacy kartlar için direkt #pacman -S nvidia ile kurulum yapıyorduk o değişmiş. Geforce 7 öncesi kartlar için
Kod: [Seç]
#pacman -S nvidia-304xx
komutuyla kurulum yapmak zorundayız yoksa nvidia modülü tanınmıyor ve X açılmıyor.


Anladım ben eklenti paketlerini kurmadığım için kaldırmama gerek kalmamıştı :D nvidia için gerekli açıklamayı şurda yapmıştım sorunu çözmüşsün ama bilgin olsun



http://archtr.org/forum/viewtopic.php?f=15&t=721
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı hsngrms

  • İleti: 1.707
Re: Son Yaşadığım Arch Deneyimi
« Yanıtla #7 : 06 Ocak 2013 - 12:38:47 »
Nvidia konusunda forumu takip edemediğiniz için biraz uğraşmışsınız, @xxx3'ün açtığı konuda ben yeni sürücünün desteklediği kartları tek tek paylaştım. 7000 serisi ve altı nvidia-304xx kullanacak diye yazdım. :) Aslında kurulum anlatımını da güncellemek lazım bu konu iyi bir vesile oldu.



GTK sorunuza gelince, eğer seçtiğiniz tema sadece GTK2 teması ise GTK3 uygulamaları çirkin görünür, sadece GTK3 teması ise GTK2 uygulamaları çirkin görünür. GTK2 ve GTK3'ü bir arada içeren temalardan birini kurmalısınız (ki böyle çok tema var gnome-look.org'dan bulabilirsiniz).

Bir de şu var, GTK3 temaları içinde GTK3.4'e kadar destek verenler ile GTK3.6 ve sonrasına destek verenler var, kullandığınız GTK uygulamaları GTK3.6 temasına uyumluysa 3.4 ve öncesi temalarda özellikle menüler falan bozuk görünür.

Anlayacağınız GTK konusu biraz karışık ama çözüm basit örnek:

http://gnome-look.org/content/show.php/GnomishDark?content=147290" class="bbc_link" target="_blank">http://http://gnome-look.org/content/show.php/GnomishDark?content=147290
Kod: [Seç]
GTK3 = 3.6.X
GNOME3 = 3.6.X
gnome-themes-standard = 3.6.X
gnome-shell = 3.6.X (for GNOME-Shell)
gtk2-engines-murrine >= 0.98.1.1 (for GTK2)
gtk2-engines-pixbuf >= 2.24.10 (for GTK2)
Metacity >= 2.34 (for GTK2)

Adamlar yazmışlar, gördüğünüz gibi GTK3.6 ve GTK2 destekli. Açıklamalara bakıp uyumlu temaları bu şekilde gnome-look'tan bulabilirsiniz. Ayrıca depodan içinde gtk engine geçen paketleri kurun. (pacman -Ss gtk engine)
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »