Haberler

Gönderen Konu: [Çözüldü] Yaourt package-query Hatası  (Okunma sayısı 202 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı Elephant Man

  • Newbie
  • *
  • İleti: 41
  • I am not an animal, i am a human being!
  • Dağıtım: Arch Linux
  • Ekran Kartı: Radeon HD 4850
: 30 Mayıs 2018 - 18:13:09
Arkadaşlar "pacman -Syu" komutu ile sistemi güncelledikten sonra yaourt'u çalıştıramıyorum, bir paket indirmek için arama yaptığımda şu hatayı veriyor;


Kod: [Seç]
yaourt java
package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory


"Arkadaşlar paketi silip tekrar kurarsam belki düzelir diye  yaout'u sileyim dedim, bu sefer sudo pacman -S yaourt yazınca da şu hatayı  veriyor;



Kod: [Seç]

hata: hedef bulunamadı: yaourt


Not: Buradaki adıamları tek tek uyguladım. https://www.archtr.org/forum/index.php?topic=6.msg8#msg8
« Son Düzenleme: 31 Mayıs 2018 - 00:19:17 Gönderen: Elephant Man »



Çevrimdışı cumali

  • Administrator
  • *****
  • İleti: 2.228
Yanıtla #1 : 30 Mayıs 2018 - 22:59:10
Aynı sorun ile bende karşılaştım. Sebebini araştırıyorum. Ancak çözümsüz degil. Aşağıdaki bağlantıdan önce package-query ardından yaourt paketini manuel olarak kurun.

https://repo.itmettke.de/aur/aur-archlinux/x86_64/
« Son Düzenleme: 30 Mayıs 2018 - 23:04:58 Gönderen: cumali »



Çevrimdışı cumali

  • Administrator
  • *****
  • İleti: 2.228
Yanıtla #2 : 30 Mayıs 2018 - 23:33:16
Alternatif olarak pacman.conf dosyasında degişiklik yapabilirsiniz. Bunun için

Kod: [Seç]
# nano /etc/pacman.conf
komutunu uygulayın. Açılan pencerede en alt kısmına

Kod: [Seç]
[aur-archlinux]
Server = https://repo.itmettke.de/aur/$repo/$arch

ekleyip kaydedin. Sonrada

Kod: [Seç]
# pacman -Syy
komutu ile senkronize ediniz. Şu anda sorunsuz çalışıyor.  https://wiki.archlinux.org/index.php/unofficial_user_repositories#aur-archlinux


Çevrimdışı Elephant Man

  • Newbie
  • *
  • İleti: 41
  • I am not an animal, i am a human being!
  • Dağıtım: Arch Linux
  • Ekran Kartı: Radeon HD 4850
Yanıtla #3 : 31 Mayıs 2018 - 00:18:17
Aynı sorun ile bende karşılaştım. Sebebini araştırıyorum. Ancak çözümsüz degil. Aşağıdaki bağlantıdan önce package-query ardından yaourt paketini manuel olarak kurun.

https://repo.itmettke.de/aur/aur-archlinux/x86_64/
Sorun çözüldü yardımınız için çok teşekkür ederim. :)



Çevrimdışı WarGasm

  • Newbie
  • *
  • İleti: 15
  • Keep It Simple Sexy!
    • Arch Linux
  • Dağıtım: Arch Linux 4.xx.x-x-zen
  • Sürüm: Rolling Release
  • Ekran Kartı: ATI
Yanıtla #4 : 01 Haziran 2018 - 22:54:50
http://allanmcrae.com/2018/05/pacman-5-1-dont-use-the-force-luke/ burada ilk yorumda aynı durumdan bahsedilmiş, ava1ar da benim bu cevabı yazma sebebimi söylemiş;
 
Alıntı
Just rebuild the package-query package to fit the yaourt, but better stop using it, since it is very outdated and insecure:

yaourt artık geliştirilmiyor ve diğer AUR yardımcılarının yaptıklarının neredeyse hiç birini yapamıyor. https://wiki.archlinux.org/index.php/AUR_helpers adresinde hangi projelerin devam ettiği, hangisinin terkedildiği görülüyor. Neleri destekleyip desteklemediği de aynı şekilde.

Pacaur güzeldi ancak o da artık devam etmiyor, bu yüzden benim önerim Pikaur olur, neredeyse herşeyi destekliyor ve paket güncellenmeye devam ediyor.
AUR sayfası :https://aur.archlinux.org/packages/pikaur/
Git adresi: https://github.com/actionless/pikaur

Arch Linux deviantART Group :
ArchLinux@deviantART ~