Haberler

:::::  YENİ  :::::
ARCHKUR

Gönderen Konu: Arch Kyk Wifi Sorunu  (Okunma sayısı 3067 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı cokomoko

  • İleti: 508
: 12 Ekim 2015 - 15:41:15
Sorun şöyle ki windows ve diğer linux'lar dahil tüm sistemlerde kyk doğrulama ekranı geliyor ama Arch'ta gelmiyor, öyle olunca da login olamıyorum, bazen de kyk doğrulama ekranı geliyor ama bu kez de yarım saat aralıklarla kopup duruyor, üstelik ben ağdan paket çekerken kopuyor.Ama diğer sistemlerde bu iki sorun da yok, neden böyle oluyor anlamıyorum, çünkü aynı sistemle komşumu wifi'sine şifreli olsun olmasın girebiliyordum, bağlantı kopunca kendisi otomatik bağlanıyordu, Kyk wifi'de öyle değil yarım saat sonra kopuyor, bağlantıyı kesip tekrar bağlanıyorum, bu böyle yarım saat aralıklarla devam ediyor, bazen ise bağlantıyı kesip tekrar bağlanmam da işe yaramıyor,hiç bağlanmayabiliyor.

Birkaç gündür çeşitli ağ yöneticileri denedim hepsinde aynı sorunu yaşıyorum ve hala sorunu çözemedim.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"


Çevrimdışı cann

  • İleti: 48
Yanıtla #1 : 16 Ekim 2015 - 11:31:10
selamün aleyküm



####     /etc/systemd/system/wifi.service    ####
Kod: [Seç]
[Unit]
Description=Wireless network connectivity
Wants=network.target
Before=network.target
BindsTo=sys-subsystem-net-devices-wlp6s0.device
After=sys-subsystem-net-devices-wlp6s0.device

[Service]
Type=oneshot
RemainAfterExit=yes

ExecStart=/usr/bin/ip link set wlp6s0 up
ExecStart=/usr/bin/wpa_supplicant -B -i wlp6s0 -c /etc/wpa_supplicant/wpa_supplicant.conf
ExecStart=/usr/bin/ip addr add 192.168.1.2/24 dev wlp6s0
ExecStart=/usr/bin/ip route add default via 192.168.1.1 dev wlp6s0

ExecStop=/usr/bin/ip addr flush dev wlp6s0
ExecStop=/usr/bin/ip link set wlp6s0 down

[Install]
WantedBy=multi-user.target

####     /etc/wpa_supplicant/wpa_supplicant.conf    ####
Kod: [Seç]

ctrl_interface=/var/run/wpa_supplicant GROUP=wheel
eapol_version=2
ap_scan=1
fast_reauth=1
country=TR

#filter_ssids=0
#mac_addr=0
#rand_addr_lifetime=60

network={
ssid="TP-LINK"
proto=RSN
key_mgmt=WPA-PSK
psk="cok_gizli_bu_haa"
}


değişkenleri uyarla.dene bakam
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı cokomoko

  • İleti: 508
Yanıtla #2 : 16 Ekim 2015 - 19:28:53
Aleyküm Selam @cann

Şu an evdeyim, yurda gidince deneyeceğim, o zaman geri dönüş yaparım.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"


Çevrimdışı cokomoko

  • İleti: 508
Yanıtla #3 : 19 Ekim 2015 - 18:52:42
denedim ama bağlanmadı, wifi.service systemd durumu şöyle:
Kod: [Seç]
┌─[cokomoko]──[cokomoko]:~$
└──>>systemctl restart wifi.service
Failed to open /run/systemd/ask-password-block/136:0: No such file or directory
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
'wifi.service' yeniden başlatmak için kimlik doğrulaması gereklidir.
Authenticating as: cokomoko
Password:
==== AUTHENTICATION COMPLETE ===
Job for wifi.service failed because the control process exited with error code. See "systemctl status wifi.service" and "journalctl -xe" for details.
┌─[cokomoko]──[cokomoko]:~$
└──>>systemctl status wifi.service
● wifi.service - Wireless network connectivity
   Loaded: loaded (/etc/systemd/system/wifi.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Pzt 2015-10-19 18:41:57 UTC; 4s ago
  Process: 27765 ExecStart=/usr/bin/ip route add default via 192.168.1.1 dev wlp20s0 (code=exited, status=2)
  Process: 2581 ExecStart=/usr/bin/ip addr add 192.168.1.2/24 dev wlp20s0 (code=exited, status=2)
  Process: 2579 ExecStart=/usr/bin/wpa_supplicant -B -i wlp20s0 -c /etc/wpa_supplicant/wpa_supplicantt.conf (code=exited, status=0/SUCCESS)
  Process: 2577 ExecStart=/usr/bin/ip link set wlp20s0 up (code=exited, status=0/SUCCESS)
 Main PID: 2581 (code=exited, status=2)

Eki 19 18:41:57 cokomoko systemd[1]: Stopped Wireless network connectivity.
Eki 19 18:41:57 cokomoko systemd[1]: Starting Wireless network connectivity...
Eki 19 18:41:57 cokomoko ip[2581]: RTNETLINK answers: File exists
Eki 19 18:41:57 cokomoko systemd[1]: wifi.service: Main process exited, code=exited, status=2/INVALIDARGUMENT
Eki 19 18:41:57 cokomoko systemd[1]: Failed to start Wireless network connectivity.
Eki 19 18:41:57 cokomoko systemd[1]: wifi.service: Unit entered failed state.
Eki 19 18:41:57 cokomoko systemd[1]: wifi.service: Failed with result 'exit-code'.
┌─[cokomoko]──[cokomoko]:~$
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"


Çevrimdışı cann

  • İleti: 48
Yanıtla #4 : 19 Ekim 2015 - 19:38:59
Sana "değişkenleri kendi ağına/donanımına göre uyarla"   demiştim.



192.168.1.1  benim modemimin  IP 'si.



192.168.1.2  benim kendi bilgisayarıma atadığım statik IP.



Önce normal bağlan. Modemin IP sine bak. Ve sana atadığı IP yi  notet.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı cokomoko

  • İleti: 508
Yanıtla #5 : 19 Ekim 2015 - 19:45:03
Hmm işler karıştı biraz çünkü ben dnsmasq da kullanıyorum sanırım ona göre de değişkenleri ayarlamam lazım.Bir iki deneyeyim olmazsa yazarım.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"


Çevrimdışı cann

  • İleti: 48
Yanıtla #6 : 19 Ekim 2015 - 19:53:05
Boşver! Statik IP  senin ağına göre değil. Direk bu komutlarla ağa bağlan.
Kod: [Seç]

sudo wpa_supplicant -B -i wlp2s0 -c /etc/wpa_supplicant/wpa_supplicant.conf
sudo dhcpcd wlp2s0


Kopma olmuyorsa bu komutları systemd servisi yaparsın artık.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı cokomoko

  • İleti: 508
Yanıtla #7 : 19 Ekim 2015 - 20:04:07
statik ip olmuyor zaten az önce bağlantı gitti denedim ama olmadı tekrar bağlantı gelince bana farklı bir ip adresi verdi, demek ki her bağlantıda yeni bir ip veriyor.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"


Çevrimdışı cokomoko

  • İleti: 508
Yanıtla #8 : 29 Ekim 2015 - 20:03:58
Bu sorunu çözdüm artık bağlantı kopmuyor ama internet linux üzerinde son derece yavaş, oysa windows'ta öyle değil.Bu Kykwifi bayağı sorunlu çıktı, illa windows diyor sanırım biraz daha kurcalamam araştırmam lazım.

Unutmazsam konuya tekrar geri bildirim yapacağım.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"