Gönderen Konu: Aur Derlemede Sorun Yaşanan Paketler  (Okunma sayısı 8680 defa)

0 Üye ve 2 Ziyaretçi konuyu incelemekte.

Çevrimdışı Z3r0nU11

  • İleti: 94
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #25 : 28 Eylül 2015 - 02:26:24 »
Oylesine derlemeniz icin PKGBUILD hazirladim.

Zira bagimliliklarini yada  eksiklerinizi programi calistirarak  bulabilirsiniz.
Kod: [Seç]

# Maintainer: Ben sen o biz siz onlar sunlar bunlar oyle gider.
#2'si bir arada nescafe kivaminda :)
pkgname=kiba-dock-plugin
pkgver=1
pkgrel=2
pkgdesc="Karala birseyler"
arch=('x86_64')
url="https://817c0d3r.github.io/"
license=('Ozgur Dunya')
#depends=('Tam olarak bakamadim')
makedepends=('rpmextract')
options=('emptydirs')
source=("ftp://fr2.rpmfind.net/linux/Mandriva/official/2011/x86_64/media/contrib/release/kiba-dock-0.1-0.1218.2mdv2011.0.x86_64.rpm"
"ftp://ftp.sunet.se/pub/Linux/distributions/mageia/distrib/1/x86_64/media/core/release/kiba-plugins-0.1-0.1218.1.mga1.x86_64.rpm")
md5sums=('ad19847c26cc0052107504a843b4c498'
'cbbd1e3bdb1aefe1a1d50c16aa6a33a1')
build() {
  cd "$srcdir"
  rpmextract.sh kiba-dock-0.1-0.1218.2mdv2011.0.x86_64.rpm
  rpmextract.sh kiba-plugins-0.1-0.1218.1.mga1.x86_64.rpm
}
package() {
  cp -r "$srcdir/usr" "$pkgdir/usr"
}

Sonuc
Kod: [Seç]
$ makepkg
==> Making package: kiba-dock-plugin 1-2 (Mon Sep 28 02:23:21 EEST 2015)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found kiba-dock-0.1-0.1218.2mdv2011.0.x86_64.rpm
  -> Found kiba-plugins-0.1-0.1218.1.mga1.x86_64.rpm
==> Validating source files with md5sums...
    kiba-dock-0.1-0.1218.2mdv2011.0.x86_64.rpm ... Passed
    kiba-plugins-0.1-0.1218.1.mga1.x86_64.rpm ... Passed
==> Extracting sources...
  -> Extracting kiba-dock-0.1-0.1218.2mdv2011.0.x86_64.rpm with bsdtar
  -> Extracting kiba-plugins-0.1-0.1218.1.mga1.x86_64.rpm with bsdtar
==> Removing existing $pkgdir/ directory...
==> Starting build()...
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
  -> Purging unwanted files...
  -> Removing libtool files...
  -> Removing static library files...
  -> Compressing man and info pages...
  -> Stripping unneeded symbols from binaries and libraries...
==> Creating package "kiba-dock-plugin"...
  -> Generating .PKGINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: kiba-dock-plugin 1-2 (Mon Sep 28 02:23:23 EEST 2015)
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
echo \"main(i){for(i=0;;i++)putchar(((i*(i>>7|i>>9)&46&i>>8))^(i&i>>9|i>>4));}\" | gcc -x c - && ./a.out | aplay

Çevrimdışı cokomoko

  • İleti: 508
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #26 : 28 Eylül 2015 - 14:20:21 »
hmm eline sağlık ben de şu an master için ders onayına geldim, akşama müsaitsen sorunlu bir kaç paket daha yazarım sana hatta vakit olursa şu multisystem üzerine gidelim diyorum malum ben de hala çalışmıyor.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"

Çevrimdışı Z3r0nU11

  • İleti: 94
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #27 : 28 Eylül 2015 - 15:01:28 »
Siz  benim butun aur paketlerini duzeltmemi istiyorsunuz ama bu munkun degil. Biliyorsunuz degil mi? :)

Ya isin esprisi bir yana, elimden geldigince yardim etmeye calisirim.

Bu aralar cok  fazla yogunum.Gecem, gunduzum karisti. :(

Multisystem de hatirladigim kadari ile erisim engeliniz vardi.

Masaustu ortaminiz neydi?

Bu sorunu sizde cozebilirsiniz.Polkit kurulumu ile.

Ben DWM uzerinde lxpolkit kullaniyorum.Xinitrc dosyasina i$li durumda ve saniyorum sorununuzu cozecektir.

O zaman da soylememis olmam lazim. mount seceneklerinizi gozden gecirmenizi.

Paketler konusuna gelirsek.Hangi paketler oldugunu paylasirsaniz, sanirim bir ara birseyler yapabilirim. :) Cok acil degilse.

Zira o zaman baska alternatiflere yonelmenizi soylemek durumundayim. :(

Ubuntu-tr de kardesim de size yardimci olmus.Ben bir sure sonra cevap veremedim. :(

Kardesime basladim.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
echo \"main(i){for(i=0;;i++)putchar(((i*(i>>7|i>>9)&46&i>>8))^(i&i>>9|i>>4));}\" | gcc -x c - && ./a.out | aplay

Çevrimdışı cokomoko

  • İleti: 508
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #28 : 28 Eylül 2015 - 15:22:43 »
Vaktiniz olduğunda bakarsınız, acillik bir durum yok ben de birkaç pakette rastladığım hatayı ve düzeltmelerini ekleyeceğim, gerçi ara ara forumda yazıyorum ama hepsi bir başlıkta olsun, derlemede sorun yaşayan buraya baksın.Bu sorunları, düzeltmeleri sadece buraya yazmıyorum paketçilere de iletiyorum, aratıyorum çözemezsem buralara yazıyorum.

Şaka maka şu multisystem'e bir daha bakacağım, bir tek onu çalıştıramadım.

Openbox kullanıyorum genelde, akşama polkit konusuna bakacağım. Kiba'yı da denemek akşama kaldı.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"

Çevrimdışı Z3r0nU11

  • İleti: 94
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
echo \"main(i){for(i=0;;i++)putchar(((i*(i>>7|i>>9)&46&i>>8))^(i&i>>9|i>>4));}\" | gcc -x c - && ./a.out | aplay

Çevrimdışı cokomoko

  • İleti: 508
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #30 : 29 Eylül 2015 - 16:19:05 »
Kod: [Seç]
─[cokomoko]──[cokomoko]:/tmp/yaourt-tmp-cokomoko$
└──>>derle
==> kiba-dock-plugin 1-2 (Sal Eyl 29 14:48:37 UTC 2015) paketi oluşturuluyor
==> Bağımlılıklar denetleniyor...
==> Derleme bağımlılıkları denetleniyor...
==> Kaynaklar getiriliyor...
  -> kiba-dock-0.1-0.1218.2mdv2011.0.x86_64.rpm indiriliyor...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  256k  100  256k    0     0  79062      0  0:00:03  0:00:03 --:--:-- 79049
  -> kiba-plugins-0.1-0.1218.1.mga1.x86_64.rpm indiriliyor...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  191k  100  191k    0     0  64088      0  0:00:03  0:00:03 --:--:-- 64107
==> Kaynak dosyaları md5sums ile doğrulanıyor...
    kiba-dock-0.1-0.1218.2mdv2011.0.x86_64.rpm ... Doğrulandı
    kiba-plugins-0.1-0.1218.1.mga1.x86_64.rpm ... Doğrulandı
==> Kaynaklar açılıyor...
  -> kiba-dock-0.1-0.1218.2mdv2011.0.x86_64.rpm ile bsdtar açılıyor
  -> kiba-plugins-0.1-0.1218.1.mga1.x86_64.rpm ile bsdtar açılıyor
==> build() işlemine başlanıyor...
==> fakeroot ortamına giriliyor...
==> package() işlemine başlanıyor...
==> Kurulum düzenleniyor...
  -> İstenmeyen dosyalar kaldırılıyor...
  -> libtool dosyaları kaldırılıyor...
  -> Statik kütüphane dosyaları kaldırılıyor...
  -> Kılavuz ve bilgi sayfaları sıkıştırılıyor...
  -> İkilik dosyalardan ve kütüphanelerden gereksiz ayıklama sembolleri ayıklanıyor...
==> "kiba-dock-plugin" paketi oluşturuluyor...
  -> .PKGINFO dosyası üretiliyor...
  -> .MTREE dosyası oluşturuluyor...
  -> Paket sıkıştırılıyor...
==> fakeroot ortamından çıkılıyor.
==> kiba-dock-plugin 1-2 (Sal Eyl 29 14:48:45 UTC 2015) paketinin derlenmesi tamamlandı
==> kiba-dock-plugin paketi pacman -U ile kuruluyor ...
[sudo] password for cokomoko:

==> HATA: Aborted by user! Exiting...

┌─[cokomoko]──[cokomoko]:/tmp/yaourt-tmp-cokomoko$
└──>>ls
kiba-dock-0.1-0.1218.2mdv2011.0.x86_64.rpm  pkg
kiba-dock-plugin-1-2-x86_64.pkg.tar.xz      PKGBUILD
kiba-plugins-0.1-0.1218.1.mga1.x86_64.rpm   src
┌─[cokomoko]──[cokomoko]:/tmp/yaourt-tmp-cokomoko$
└──>>yukle kiba-dock-plugin-1-2-x86_64.pkg.tar.xz
[sudo] password for cokomoko:
paketler yükleniyor...
paket bağımlılıkları çözümleniyor...
varsa paketler arası çakışmalara bakılıyor...

Paketler (1) kiba-dock-plugin-1-2

Toplam Kurulum Boyutu:  1,21 MiB

:: Kuruluma onay veriyor musunuz? [E/h] e
(1/1) anahtarlıktaki anahtarlar kontrol ediliyor   [----------------------] 100%
(1/1) paket bütünlüğü kontrol ediliyor             [----------------------] 100%
(1/1) paket dosyaları yükleniyor                   [----------------------] 100%
(1/1) dosya çakışmaları kontrol ediliyor           [----------------------] 100%
hata: işlem gerçekleştirilemedi (çakışan dosyalar)
kiba-dock-plugin: /usr/lib64 dosya sisteminde mevcut
Hata oluştu, hiçbir paket güncellenmedi.


Böyle dedi ama /usr/lib64 altında kiba adına hiçbir dosya yoktu, ben de derlenen paketten kiba ile ilgili dosyaları elle istediği dizinlere koydum ve sorunsuz çalıştı

http://i.imgur.com/gNbEcXG.png



Şimdi multisystem'e bakacağım.



Not:Resimi bir türlü ekleyemedim foruma sürekli yükleniyor diyor yüklenmiyor, forumda bir sıkıntı var.@decent umarım yakın zamanda düzeltir.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"

Çevrimdışı Z3r0nU11

  • İleti: 94
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #31 : 29 Eylül 2015 - 16:30:04 »
@cokomoko;

PKGBUILD icin ozen gosteremedim ama zorbey modu is yapar saniyorum.
Kod: [Seç]

# pacman -U senin_adin_nedir_paket.tar.xz --force
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
echo \"main(i){for(i=0;;i++)putchar(((i*(i>>7|i>>9)&46&i>>8))^(i&i>>9|i>>4));}\" | gcc -x c - && ./a.out | aplay

Çevrimdışı cokomoko

  • İleti: 508
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #32 : 29 Eylül 2015 - 17:43:50 »
Kod: [Seç]
yukle kiba-dock-plugin-1-2-x86_64.pkg.tar.xz --force
[sudo] password for cokomoko:
paketler yükleniyor...
paket bağımlılıkları çözümleniyor...
varsa paketler arası çakışmalara bakılıyor...

Paketler (1) kiba-dock-plugin-1-2

Toplam Kurulum Boyutu:  1,21 MiB

:: Kuruluma onay veriyor musunuz? [E/h] e
(1/1) anahtarlıktaki anahtarlar kontrol ediliyor   [----------------------] 100%
(1/1) paket bütünlüğü kontrol ediliyor             [----------------------] 100%
(1/1) paket dosyaları yükleniyor                   [----------------------] 100%
(1/1) dosya çakışmaları kontrol ediliyor           [----------------------] 100%
(1/1) disk alanı kontrol ediliyor                  [----------------------] 100%
(1/1) yükleniyor kiba-dock-plugin                  [----------------------] 100%


oldu zorbey, kuracaklar da öyle denerler artık kiba çok güzelmiş sevdim kiba'yı sağol.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"

Çevrimdışı Z3r0nU11

  • İleti: 94
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #33 : 30 Eylül 2015 - 15:14:52 »
Rica ederim.

Sorunsuz kullanimlar dilerim. :)
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
echo \"main(i){for(i=0;;i++)putchar(((i*(i>>7|i>>9)&46&i>>8))^(i&i>>9|i>>4));}\" | gcc -x c - && ./a.out | aplay

Çevrimdışı cokomoko

  • İleti: 508
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #34 : 01 Ekim 2015 - 21:32:40 »






Ya şimdi kiba'yı yükledik ama bu videolardaki gibi physic özelliği vs. özellikleri yok bu kiba'da eski sürüm mü ne bu bizim kurduğumuz, bu özellikteki kiba'yı derliyorum ama derlemede hata veriyor, zamanın varsa bir bak istersen.

https://launchpad.net/kiba-dock


Kod: [Seç]
/usr/sbin/ld: startup-notification.o: undefined reference to symbol 'XPending'
/usr/lib/libX11.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
Makefile:694: recipe for target 'kiba-dock' failed
make[4]: *** [kiba-dock] Error 1
make[4]: Leaving directory '/tmp/yaourt-tmp-cokomoko/new/src/kiba-dock/src'
Makefile:798: recipe for target 'all-recursive' failed
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory '/tmp/yaourt-tmp-cokomoko/new/src/kiba-dock/src'
Makefile:520: recipe for target 'all' failed
make[2]: *** [all] Error 2
make[2]: Leaving directory '/tmp/yaourt-tmp-cokomoko/new/src/kiba-dock/src'
Makefile:541: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/tmp/yaourt-tmp-cokomoko/new/src/kiba-dock'
Makefile:450: recipe for target 'all' failed
make: *** [all] Error 2
==> HATA: package() içinde bir hata oluştu.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"

Çevrimdışı cokomoko

  • İleti: 508
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #35 : 01 Ekim 2015 - 21:39:40 »
Hatta istediğim kiba'nın eski pkgbuıld'ini arşivimden buldum, buraya geçeyim bir de sen derle
Kod: [Seç]
# Contributor: sickhate <vivid@tux-linux.net>

pkgname=kiba-dock-svn
pkgver=861
pkgrel=1
pkgdesc="a fun dock program for Compiz"
arch=('i686'  'x86_64')
url="http://www.kiba-dock.org/"
license=('GPL')
depends=('librsvg' 'akamaru-svn' 'gnome-desktop')
makedepends=('subversion' 'pkgconfig' 'intltool')
conflicts=('kiba-dock'  'kibadock')
provides=('kiba-dock')
source=()
md5sums=()

_svntrunk=https://kibadock.svn.sourceforge.net/svnroot/kibadock/trunk
_svnmod=kiba

package() {
msg "Connecting to SVN server..."
msg "Checking out $_svnmod"
svn co $_svntrunk --config-dir ./ $_svnmod
cp -r $startdir/src/kiba/kiba-dock $startdir/src/
cd "$startdir/src/kiba-dock/"
CC="gcc -fPIC" ./autogen.sh --prefix=/usr
make || return 1
make DESTDIR=${startdir}/pkg install
rm -rf $startdir/src/$_svnmod
}

akamaru şu an aur'da var zaten onu geçmedim.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"

Çevrimdışı Z3r0nU11

  • İleti: 94
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #36 : 01 Ekim 2015 - 22:15:44 »
Makefile dosyasina asagida ki parametreleri ekleyebilirseniz sorunsuz derleyebilirsiniz.

Uyari satiri.
Kod: [Seç]

/usr/sbin/ld: startup-notification.o: undefined reference to symbol 'XPending'
/usr/lib/libX11.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status

Eklenecek parametreler
Kod: [Seç]

LIBS="-lX11 -lXft"
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
echo \"main(i){for(i=0;;i++)putchar(((i*(i>>7|i>>9)&46&i>>8))^(i&i>>9|i>>4));}\" | gcc -x c - && ./a.out | aplay

Çevrimdışı cokomoko

  • İleti: 508
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #37 : 01 Ekim 2015 - 22:48:18 »
ekledim şimdi böyle diyor
Kod: [Seç]
libtool: link: gcc -fPIC -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fstack-check -Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z -Wl,relro -o kiba-dock main.o kiba.o transparent-window.o win.o dock.o dock-menu.o dnd-window.o plugin-loader.o plugin.o object.o drawable-object.o icon.o container-object.o separator.o title.o visual-feature.o prefs-dbus.o screen.o window.o x11.o icon-factory.o menu-items.o shapes/default-shape.o shapes/podest-shape.o features/reflection.o features/shadow.o features/prelight.o features/greyed.o features/activity.o features/progress.o features/continuous-progress.o ../common/cached-icon.o ../common/desktop-icon.o ../common/utils.o ../common/cairo-utils.o ../common/debug.o ../common/dialog.o ../common/key-file.o ../marshaller/marshallers.o ../preferences/prefs.o ../preferences/prefs-schema.o ../widgets/tooltip.o ../widgets/app-chooser.o ../widgets/icon-view-win.o ../widgets/icon-view.o ../widgets/info-win.o ../widgets/info-win-manager.o ../widgets/image.o ../widgets/desktop-editor.o startup-notification.o -pthread -pthread -Wl,--export-dynamic  -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangoft2-1.0 -lfontconfig -lfreetype -lxml2 -ldbus-glib-1 -ldbus-1 -lpangocairo-1.0 -lpango-1.0 -lgthread-2.0 -lrsvg-2 -lm -lgio-2.0 -lcairo -lgdk_pixbuf_xlib-2.0 -lgmodule-2.0 -lgdk_pixbuf-2.0 -lgobject-2.0 -lglib-2.0 -lstartup-notification-1 -lpthread -lX11 -lXft -pthread
/usr/sbin/ld: plugin.o: undefined reference to symbol 'dlclose@@GLIBC_2.2.5'
/usr/lib/libdl.so.2: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
Makefile:694: recipe for target 'kiba-dock' failed
make[4]: *** [kiba-dock] Error 1
make[4]: Leaving directory '/tmp/yaourt-tmp-cokomoko/new/src/kiba-dock/src'
Makefile:798: recipe for target 'all-recursive' failed
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory '/tmp/yaourt-tmp-cokomoko/new/src/kiba-dock/src'
Makefile:520: recipe for target 'all' failed
make[2]: *** [all] Error 2
make[2]: Leaving directory '/tmp/yaourt-tmp-cokomoko/new/src/kiba-dock/src'
Makefile:541: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/tmp/yaourt-tmp-cokomoko/new/src/kiba-dock'
Makefile:450: recipe for target 'all' failed
make: *** [all] Error 2
==> HATA: package() içinde bir hata oluştu.
    Çıkılıyor...
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"

Çevrimdışı Z3r0nU11

  • İleti: 94
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #38 : 01 Ekim 2015 - 22:53:58 »
LDFLAGS= -ldl
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
echo \"main(i){for(i=0;;i++)putchar(((i*(i>>7|i>>9)&46&i>>8))^(i&i>>9|i>>4));}\" | gcc -x c - && ./a.out | aplay

Çevrimdışı cokomoko

  • İleti: 508
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #39 : 01 Ekim 2015 - 22:57:08 »
şimdi oldu derlendi bakalım çalışacak mı paket?
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"

Çevrimdışı cokomoko

  • İleti: 508
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #40 : 02 Ekim 2015 - 01:21:04 »
Derledim çalıştı ama bunda da physic özelliği yoktu, neyse aur'daki paketçi 64 bit bağımlılıkları yüklemiş paketi derliyorum ama bağımlılıkların sonu gelmiyor, allahım ne paketmiş yahu bu kadar bağımlılık mı olur.

2007'den kalma rpm 64 bit paketini bulup kurdum ama onda da libssl falan filan bağımlılığı çıktı, bugünlük bu kadar yeter yarına devam ederim.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"

Çevrimdışı cokomoko

  • İleti: 508
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #41 : 02 Ekim 2015 - 03:03:25 »
Ve azmin zaferi sonunda kurdum physic özelliği de var.

http://i.imgur.com/unTnSAW.png
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"

Çevrimdışı Z3r0nU11

  • İleti: 94
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #42 : 02 Ekim 2015 - 11:15:05 »
O zaman gecmis olsun diyelim @cokomoko. :)
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
echo \"main(i){for(i=0;;i++)putchar(((i*(i>>7|i>>9)&46&i>>8))^(i&i>>9|i>>4));}\" | gcc -x c - && ./a.out | aplay

Çevrimdışı cokomoko

  • İleti: 508
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #43 : 02 Ekim 2015 - 22:53:40 »
aqemu paketinde şöyle bir hata alıyorum
Kod: [Seç]
[ 78%] Built target docs
Scanning dependencies of target icons
[ 79%] Generating crystalsvg_icons.rcc
make[2]: rcc: Komut bulunamadı
CMakeFiles/icons.dir/build.make:61: recipe for target 'crystalsvg_icons.rcc' failed
make[2]: *** [crystalsvg_icons.rcc] Error 127
CMakeFiles/Makefile2:141: recipe for target 'CMakeFiles/icons.dir/all' failed
make[1]: *** [CMakeFiles/icons.dir/all] Error 2
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2
==> HATA: build() içinde bir hata oluştu.
    Çıkılıyor...


lxpolkit-git paketinde de şöyle
Kod: [Seç]
==> build() işlemine başlanıyor...
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/${ <-- HERE ([^ t=:+{}]+)}/ at /usr/sbin/automake line 3936.

You must have automake > 1.10 or 1.11 installed to compile this program.
Install the appropriate package for your distribution,
or get the source tarball at http://ftp.gnu.org/gnu/automake/
==> HATA: build() içinde bir hata oluştu.
    Çıkılıyor...
==> HATA:makepkg lxpolkit-git'i inşa edemedi.

galiba automake eski sürümüne dönmemi istiyor.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"

Çevrimdışı Z3r0nU11

  • İleti: 94
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #44 : 03 Ekim 2015 - 12:14:51 »
aqemu icin yuklemen gereken
Kod: [Seç]

make[2]: rcc: Komut bulunamadı

lxpolkit
Kod: [Seç]

# pacman -S lxsession
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
echo \"main(i){for(i=0;;i++)putchar(((i*(i>>7|i>>9)&46&i>>8))^(i&i>>9|i>>4));}\" | gcc -x c - && ./a.out | aplay

Çevrimdışı cokomoko

  • İleti: 508
Re: Aur Derlemede Sorun Yaşanan Paketler
« Yanıtla #45 : 04 Ekim 2015 - 03:05:52 »
Resmi depoya geçen zen kerneli kullanmam için nvidia'yı derlemem gerekiyordu, bunun için  Aur3'teki eski nvidia-zen paketini kendime uyarladım,  aşağıya geçiyorum, belki işine yarayan olur veya kendi nvidia paketini oluşturmak isteyen


Alıntı
PKGBUILD

Kod: [Seç]
# Contributor: Amaury Couste <amaury.couste@gmail.com>
# Contributor: Artem Vorotnikov <artem@vorotnikov.me>
# Contributor: A.J. Korf <jacobkorf at gmail dot com>
# Contrubutor: ilikenwf/Matt Parnell <parwok@gmail.com>
# Contributor: James Rayner <iphitus@gmail.com>
# Contributor: Bartek Piotrowski <barthalion@gmail.com>
# Contributor: Det <nimetonmaili AT gmail dot com>
# Contributor: Dan Vratil <vratil@progdansoft.com>
# Contributor: graysky <graysky AT archlnux.us>
# Contributor: mar77i <mysatyre at gmail dot com>
# Contributor: Ng Oon-Ee <n g o o n e e AT g mail dot com>
# Contributor: Nuno Aniceto aka quarkup <nuno.aja@gmail.com>
# Contributor: Peter Maatman <blackwolf12333@gmail.com>
# Contributor: Thomas Baechler <thomas@archlinux.org>
#                   DÜZENLEME: Cokomoko <<< cokomoko@bsd-tr.org >>> www.archtr.org


pkgname=nvidia-340xx-zen
pkgver=340.93
_extramodules=extramodules-4.2-zen
pkgrel=1
_pkgdesc="NVIDIA drivers for linux-zen."
pkgdesc="$_pkgdesc"
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
depends=('linux-zen' "nvidia-340xx-libgl" "nvidia-340xx-utils=${pkgver}")
makedepends=('linux-zen-headers')
conflicts=('nvidia-340xx-zen' 'nvidia-304xx-zen' 'nvidia-275xx-zen' 'nvidia-319-zen' 'nvidia-96xx-zen' 'nvidia-beta-zen' 'nvidia-zen-atom' 'nvidia-zen-barcelona' 'nvidia-zen-bulldozer' 'nvidia-zen-corex' 'nvidia-zen-core2' 'nvidia-zen-haswell' 'nvidia-zen-ivybridge' 'nvidia-zen-kx' 'nvidia-zen-k10' 'nvidia-zen-nehalem' 'nvidia-zen-p4' 'nvidia-zen-piledriver' 'nvidia-zen-pentm' 'nvidia-zen-sandybridge' 'nvidia-304xx-zen-atom' 'nvidia-304xx-zen-barcelona' 'nvidia-304xx-zen-corex' 'nvidia-304xx-zen-core2' 'nvidia-304xx-zen-haswell' 'nvidia-304xx-zen-ivybridge' 'nvidia-304xx-zen-kx' 'nvidia-304xx-zen-k10' 'nvidia-304xx-zen-nehalem' 'nvidia-304xx-zen-p4' 'nvidia-304xx-zen-piledriver' 'nvidia-304xx-zen-pentm' 'nvidia-304xx-zen-sandybridge' 'nvidia-340xx-zen-atom' 'nvidia-340xx-zen-barcelona' 'nvidia-340xx-zen-bulldozer' 'nvidia-340xx-zen-core2' 'nvidia-340xx-zen-haswell' 'nvidia-340xx-zen-ivybridge' 'nvidia-340xx-zen-kx' 'nvidia-340xx-zen-k10' 'nvidia-340xx-zen-nehalem' 'nvidia-340xx-zen-p4' 'nvidia-340xx-zen-piledriver' 'nvidia-340xx-zen-pentm' 'nvidia-340xx-zen-sandybridge')
#groups=('zen-generic')
#replaces=()
license=('custom')
install=nvidia-zen.install
options=(!strip)
source=("nv-drm.patch")
source_i686+=("ftp://download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64+=("ftp://download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
md5sums=('2365f1405f0c7bbb8f8cd7ebd5e4e301')
md5sums_i686=('eae5d5407df0b371929a76f96aec4020')
md5sums_x86_64=('cb80e3f1cb6f2fb6e6eab35fad0884e4')
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"

prepare() {
    sh "${_pkg}.run" --extract-only
    cd "${_pkg}"
    # patches here
patch -Np0 -i "$srcdir/nv-drm.patch"
}

build() {
_kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
cd "${_pkg}/kernel"
make SYSSRC=/usr/lib/modules/"${_kernver}/build" module

cd uvm
make SYSSRC=/usr/lib/modules/"${_kernver}/build" module
}

package() {
install -Dm644 "${srcdir}/${_pkg}/kernel/nvidia.ko"
"${pkgdir}/usr/lib/modules/${_extramodules}/nvidia.ko"
install -D -m644 "${srcdir}/${_pkg}/kernel/uvm/nvidia-uvm.ko"
"${pkgdir}/usr/lib/modules/${_extramodules}/nvidia-uvm.ko"
gzip -9 "${pkgdir}/usr/lib/modules/${_extramodules}/"*.ko
install -dm755 "${pkgdir}/usr/lib/modprobe.d"
echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-zen.conf"
}

Alıntı
nvidia-zen.install

Kod: [Seç]
post_install() {
EXTRAMODULES='extramodules-4.2-zen'
depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
echo 'In order to use nvidia module, reboot the system.'
}

post_upgrade() {
EXTRAMODULES='extramodules-4.2-zen'
depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
if [ "$(vercmp $2 310.19-2)" -lt 0 ]; then
echo 'If your card is from the 7xxx series or earlier, install nvidia-304xx-zen'
fi
}

post_remove() {
EXTRAMODULES='extramodules-4.2-zen'
depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
}

Alıntı
nv-drm.patch

Kod: [Seç]
--- kernel/nv-drm.c~ 2014-09-12 00:33:06.000000000 +0200
+++ kernel/nv-drm.c 2014-10-14 11:35:52.854400737 +0200
@@ -18,6 +18,11 @@

 #include <drm/drmP.h>

+/* 3.18-rc0+ */
+#ifndef drm_gem_object
+#include <drm/drm_gem.h>
+#endif
+
 extern nv_linux_state_t *nv_linux_devices;

 struct nv_gem_object {
diff --git a/kernel/nv-drm.c~ b/kernel/nv-drm.c
index ecc982a..60d7aae 100644
--- kernel/nv-drm.c~
+++ kernel/nv-drm.c
@@ -129,6 +129,8 @@ static struct drm_driver nv_drm_driver = {
     .gem_prime_vmap = nv_gem_prime_vmap,
     .gem_prime_vunmap = nv_gem_prime_vunmap,

+    .set_busid = drm_pci_set_busid,
+
     .name = "nvidia-drm",
     .desc = "NVIDIA DRM driver",
     .date = "20130102",


paketi sürekli kullanmak isteyen kullanıcılar hem kernel hem de nvidia paket yükseltmesi olduğunda pkgbuild ve diğer dosyaların içeriğini buna göre değiştirmek zorundalar, yoksa derleme başarılı olmaz, ne zen kerneli ne de nvidia-zen paketini kullanamazsınız.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »
\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"