Haberler

[Nasıl] Güncellemelerle gelen Mpd Sorunlarının Çözümü

cokomoko · 6514

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı cokomoko

    • İleti: 508
Eğer siz de benim gibi müzik dinlemek için mpd ve konsol tabanlı ncmpcpp kullanıyorsanız son mpd ve libnfs güncellemeleriyle keyfiniz kaçabilir, çünkü mpd servisi bir şekilde çalışmıyor.Bu sorunu çözmek için mpd ve libnfs paketlerini downgrade etmek gerekiyor.

mpd ve libnfs paketlerini şu sürümlerine geri çekerseniz sorunu çözmüş olursunuz:
Kod: [Seç]
mpd 0.19.5-1
libnfs 1.9.4-1

Yapmanız gereken şey
Kod: [Seç]
downgrade mpd
veya
Kod: [Seç]
downgrade libnfs
dediğinizde yukarıda sürümleri seçmek olacaktır.

Keyifli müzik dinlemeler :)

http://i.imgur.com/mU2kZDD.jpg" alt="" class="bbc_img" />
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"


Çevrimdışı Z3r0nU11

    • İleti: 94
Yanıtla #1 : 12 Nisan 2015 - 10:59:59
@cokomoko ben de sistemi guncelledim ama bir sorun yasamadim mpd de.

Sizden baska sorun yasayan var mi?

« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

echo \"main(i){for(i=0;;i++)putchar(((i*(i>>7|i>>9)&46&i>>8))^(i&i>>9|i>>4));}\" | gcc -x c - && ./a.out | aplay


Çevrimdışı cokomoko

    • İleti: 508
Yanıtla #2 : 12 Nisan 2015 - 17:34:52
Bilmiyorum ki üst sürüme güncelleyince müziği çalacağı dizine bağlanamıyor.Ama paketleri dediğim sürümlere downgrade edince sorunsuz çalışıyor.Bir de ben testing depodan da güncelleme aldığım için sorun yaşamış olabilirim.

Forumda mpd kullanan var mı?
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"


Çevrimdışı cokomoko

    • İleti: 508
Yanıtla #3 : 12 Nisan 2015 - 23:37:20
Az önce sistemi yeniden güncelledim ve son sürüm mpd libnfs paketlerini de kurdum, bu sefer mpd'de bir sorun çıkmadı, şu an sorunsuz çalışıyor.
Kod: [Seç]
pacman -Qi mpd
İsim                       : mpd
Sürüm                      : 0.19.9-3
Açıklama                   : Flexible, powerful, server-side application for
                             playing music
Mimari                     : x86_64
URL                        : http://www.musicpd.org/
Lisanslar                  : GPL
Gruplar                    : Hiçbiri
Sağladıkları               : Hiçbiri
Bağımlılıkları             : libao  ffmpeg  libmodplug  audiofile  libshout
                             libmad  curl  faad2  sqlite  jack  libmms  wavpack
                             avahi  libid3tag  yajl  libmpdclient  icu  libupnp
                             libnfs
Opsiyonel Bağımlılık(lar)  : Hiçbiri
İhtiyaç Duyan Paket(ler)   : Hiçbiri
İsteğe bağlı    : Hiçbiri
Çakıştığı Paket(ler)       : Hiçbiri
Değiştirdiği Paket(ler)    : Hiçbiri
Kurulum boyutu   : 802,00 KiB
Paket Sorumlusu            : Gaetan Bisson <bisson@archlinux.org>
Derlenme Tarihi            : Cum 03 Nis 2015 18:28:32 UTC
Kurulum Tarihi             : Paz 12 Nis 2015 19:10:36 UTC
Kurulum Sebebi             : Doğrudan kurulmuş
Kurulum Betiği             : Evet
Doğrulayan    : İmza
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"


Çevrimdışı Z3r0nU11

    • İleti: 94
Yanıtla #4 : 13 Nisan 2015 - 17:36:27
Bende cunku sorun cikmamisti.Siz de cikmasi acaba genel bir sorun mu diye dusundum ama degilmis.

Geri bildirim icin tesekkurler @cokomoko.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

echo \"main(i){for(i=0;;i++)putchar(((i*(i>>7|i>>9)&46&i>>8))^(i&i>>9|i>>4));}\" | gcc -x c - && ./a.out | aplay


Çevrimdışı cokomoko

    • İleti: 508
Yanıtla #5 : 13 Nisan 2015 - 17:44:19
Bazen testing depodan çektiğim bazı paketler sorunlara yol açabiliyor galiba ondan dolayı oldu.Bunun dışında bir ihtimal daha var,  benim gibi sabırsız olup sadece belirli peketleri yükseltip diğerlerini olduğu gibi bırakmayın, dün firefox ve libreoffice hariç her şeyi güncelledim, bu kez de firefox ve libreoffice açılmadı, sistemi toplu güncelledim ve sorun çözüldü.

Onun için toplu olarak yükseltmeyi öneriyorum.Sabırsız olup sadece belli bir paketi çekmeyin.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"


Çevrimdışı cokomoko

    • İleti: 508
Yanıtla #6 : 12 Aralık 2015 - 18:52:42
1-2 gün önce mpd'yi 0.19.11-3 sürümüne güncelledim ve systemd açılışta şöyle bir hata vermeye başladı:
Kod: [Seç]
systemd[1]: [/lib/systemd/system/mpd.service:11] Failed to parse resource
> value, ignoring: -1


Şu anlık geliştirici listelerinde şöyle bir çözüm mevcut:

İlgili dosyadaki
Alıntı
LimitRTTIME=-1
yerine
Alıntı
LimitRTTIME=infinity
yazıyoruz ve yeniden başlatınca sorun çözülüyor.



http://comments.gmane.org/gmane.comp.audio.musicpd.devel/3412

http://osdir.com/ml/general/2015-12/msg03252.html
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"