Haberler

Gönderen Konu: [Çözüldü]Kablosuz Klavye LogitechK360 Türkçe Karakter Sorunu  (Okunma sayısı 2737 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı cokomoko

  • İleti: 508
Arkadaşlar yeni uniflaying klavye aldım logitech k360, ancak türkçe karakter yazarken sorun çıkarıyor. Laptobun kendi klavyesinden türkçe bir karaktere tıklayıp yazınca logitech k360'da da türkçe karakter yazılabiliyor veya setxkbmap layout tr komutunu verirsem o zaman da türkçe karakter yazabiliyorum.

Sorun bunu bilgisayar her açıldığında tekrar tekrar yapmak istememem.Çözümü bilen varsa yardım etsin, lütfen.


Kod: [Seç]
[cokomoko@cokomoko ~]$ localectl
   System Locale: LANG=tr_TR.UTF-8
       VC Keymap: trq
      X11 Layout: trq
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"


Çevrimdışı iceboy

  • İleti: 68
Yanıtla #1 : 18 Haziran 2014 - 15:01:03
Normalde bu anlatacağımı kurulumda yapmış olmanız gerekiyor ama belki atlamışsınızdır veya dosya değişmiştir diye tekrar deneyelim.



[c]nano /etc/X11/xorg.conf.d/10-evdev.conf[/c] (Root olarak bu komutu verin)



deyip açılan sayfada ;





    Section "InputClass"

           Identifier "evdev keyboard catchall"

           MatchIsKeyboard "on"

           MatchDevicePath "/dev/input/event*"

           Driver "evdev"

    EndSection



Driver ile EndSection arasına aşağıdaki satırı ekleyin ( kırmızı satırı aynen alttaki gibi ekleyip ctrl + o ile kaydedip ctrl + x ile çıkın)



    Section "InputClass"

           Identifier "evdev keyboard catchall"

           MatchIsKeyboard "on"

           MatchDevicePath "/dev/input/event*"

           Driver "evdev"

           Option "XkbLayout" "tr"

    EndSection





sonra yeniden başlatın.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı cokomoko

  • İleti: 508
Yanıtla #2 : 18 Haziran 2014 - 15:02:55
Kod: [Seç]
[cokomoko@cokomoko ~]$ cat /etc/X11/xorg.conf.d/10-evdev.conf
#
# Catch-all evdev loader for udev-based systems
# We don't simply match on any device since that also adds accelerometers
# and other devices that we don't really want to use. The list below
# matches everything but joysticks.

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout" "tr"
EndSection

Section "InputClass"
        Identifier "evdev touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"


Çevrimdışı iceboy

  • İleti: 68
Yanıtla #3 : 18 Haziran 2014 - 15:35:20
Sizin klavyeniz hariciydi doğru gözümden kaçmış.



Belki harici klavyeyle ilgili ayrı bir satır ekleniyordur oraya ?
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı cokomoko

  • İleti: 508
Yanıtla #4 : 18 Haziran 2014 - 15:41:33
Bekleyelim bakalım belki bilen biri çıkar.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"


Çevrimdışı cokomoko

  • İleti: 508
Yanıtla #5 : 18 Haziran 2014 - 17:42:33
tamam sorunu şöyle çözdüm ben openbox kullandığım için autostart dosyasına
Kod: [Seç]
setxkbmap -layout tr &

komutunu ekledim ve sorun çözüldü, diğer masaüstü ortamlarını kullananlar açılışta çalışması için bu komutu ekleyebilirler.

Belki başka bir yolu vardır ama şimdilik bulamadım, araştırmalarım devam etmekle birlikte sorun çözülmüştür.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

\'\'Eğer 386BSD ben Linux\'a başladığımda var olsaydı, Linux büyük bir olasılıkla olmazdı.\"

......................................................Linus Torvalds....................................................

\"Birgün herkes Archer olacak!\"