Haberler

[Çözüldü] Çhakra Linux Host Problemi

DoubleT · 2129

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı DoubleT

    • İleti: 71
: 06 Mart 2014 - 18:02:55
Merhabalar. Artık canıma tak eden bir konu var eğer çözüme ulaştıramazsam sanırım Linux kullanmayı bırakacağım. 1 senedir sadece Linux kullanıyorum. Bu süre zarfında bir sürü dağıtım denedim fakat hangisini kullanırsam kullanayım, internet tarayıcısı ile sorunsuz girebildiğim siteleri kullanan programlarda "host not found" "can not resolve host" benzeri hatalar alıyorum. Örneğin daha dün denemediğim Twitter Client'i kalmadı hepsi aynı hatayı verdi fakat twitter'a sorunsuz girebiliyorum. Ya da dolphin'de film afişleri görünmesi için MovieThumbs kullanıyorum fakat internetten afişi çekemiyor. Git, launchpad, bazaar için de aynı AUR CCR gibi depolardan program kurmak tam bir çile oluyor. Hosts dosyasını düzenleyip git için falan durumu çözüyorum ping ile IP'sini alıp fakat ne moviethumbs çalışıyor ne de twitter istemcileri. Bunlar şu an yaşadığım sorunlar olduğu için söylüyorum daha buna benzer çok programda aynı şeyi yaşadım. Wget'i ipv4 kullanmaya zorlarsam çalışıyor diğer türlü o da aynı hatayı veriyor, curl de sadece ipv4 kullanınca çalışıyor. IPv4'den desem kapatıyorum bağlantım için IPv4'ü fakat yine değişen bir şey yok ayar yapmadıkça çalışmıyorlar. Google DNS kullanıyorum yine değişen bir şey yok. İnternette çözüm arıyorum yok ya da var ben anlamıyorum çünkü çok garip şeylerden bahsediyorlar. Kendi yağında kavrulan biriyim çok bi teknik bilgim yok o yüzden kısılıp kaldım, windows'a da dönmek istemiyorum fakat çıldırdım artık. Allah'tan Firefox ve pidgin tarzı uygulamalarda böyle sorunlar çıkmıyor. Lütfen yardımcı olun.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı cumali

  • Administrator
  • *****
    • İleti: 2.228
Yanıtla #1 : 07 Mart 2014 - 16:37:58
[profile]DoubleT[/profile]



Linux kullanıp kullanmama tercihi elbette size ait. Arch kullanımındaki muhtemel sorunlar için elimizden geldikçe destek veriyoruz. Sorunlarınızı anlaşılır bir şekilde aktarmanız halinde kısa sürede cevap vermemize vesile olacaktır. Mesajından anladığım kadarı ile Chakra Linux kullanıyorsunuz. Zira CCR depodan paket alan sadece Chakra Linux bulunmaktadır ve bu dağıtıma has bir özelliktir. Yanılıyorsam düzeltin lütfen. Öte yandan kişisel yapılandırmayı doğru yapmanız sorunsuz kullanımı sağlayacaktır. DNS konusuna gelince, şu çıktıyı alalım önce:
Kod: [Seç]
$ cat /etc/resolv.conf
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı DoubleT

    • İleti: 71
Yanıtla #2 : 07 Mart 2014 - 18:24:49
Linux'u kullanmaya başladığımdan beri vazgeçilmezim oldu ama bu soru çileden çıkardı artık beni ya. Çok teşekkür ediyorum cevabın için. Evet Chakra kullanıyorum şu anda ama bu sorun Chakra'ya has bir sorun değil. Manjaro, Antergos, Chakra, SolydK kullandım uzun soluklu diyebileceğim hepsinde de aynı sorun vardı. Ubuntu ya da Ubuntu tabanlı dağıtımları uzun süre kullanmadığım için aynı sorun var mı bilmiyorum. Ama Debian tabanlı olarak SolydK'da da aynı şey vardı.


Kod: [Seç]

[doublet@chakra ~]$ cat /etc/resolv.conf
# Generated by NetworkManager
# nameserver 192.168.1.1
nameserver 8.8.8.8
nameserver 8.8.4.4


Normalde varsayılan neyse resolv.conf o şekilde oluyordu sadece Google DNS ekliyordum fakat ubuntu forumunda gördüm sadece eklediğiniz dns kalsın otomatik üretileni iptal edin yazmışlar o yüzden 192li olanı iptal ettim. Google DNS olsun olmasın bu sorun var ama.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı DoubleT

    • İleti: 71
Yanıtla #3 : 08 Mart 2014 - 00:55:24
Chakra Forum'dan biri /etc/sysctl.conf dosyasına alttakileri eklememi söyledi, bunu yapınca choqok sorunsuz çalışmaya başladı ama turpial moviethumbs falan hala çalışmıyor.


Kod: [Seç]

# IPv6
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı DoubleT

    • İleti: 71
Yanıtla #4 : 09 Mart 2014 - 13:28:51
Üstteki çözüm kısmen çözüyordu fakat fikir verdi ve arch wiki'den ipv6'yı kapatmanın başka yolu yok mu diye baktım, kernel satırına ipv6.disable=1 eklemek sorunu çözdü.



https://wiki.archlinux.org/index.php/IPv6#Disable_IPv6
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »



Çevrimdışı cumali

  • Administrator
  • *****
    • İleti: 2.228
Yanıtla #5 : 09 Mart 2014 - 14:05:03
[profile]DoubleT[/profile]



Sorunu araştırarak çözmüş olmana sevindim. Ancak hala neden ipv6 ayarlarını kullanmış olmanı anlayamadım. Bugüne kadar bir kez olsun bu ayarları kullanmış degilim. DNS kullanmak istersem ya ağ bağlantılarından ipv4 ayarları üzerinden atama yaparım,yada /etc/resolv.conf dosyasını düzenlerim. Geri bildirim için teşekkür ederim. Umarım verdigin bilgiler benzer sorun yaşayan başka arkadaşlara faydalı olur.  Başlığıda mesaja uygun halde yeniden düzenledim.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »