Gönderen Konu: Pacman'i bozdum, yeniden kuramiyorum.  (Okunma sayısı 880 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı mnyak

  • Newbie
  • *
  • İleti: 3
Pacman'i bozdum, yeniden kuramiyorum.
« : 28 Temmuz 2013 - 18:02:28 »
Merhabalar,



Olay ilk olarak bir svn'den check out yapmaya calismamla basladi ve check out yapmaya calistigimda libsasl2.so.2 dosyasinin bulunamadigi yonunde bir hata aliyordum. Sonra pacman ile subversion'i yeniden yuklemeye calistim fakat yukledikten sonra ayni hatayi vermeye devam ediyordu ve subversion paketinin icinden gelen dosyalara baktigimda zaten libsasl2.so3 vardi ama libsasl2.so2 yoktu. Subversion'in bunu istemesinden dolayi pacman'da bir problem oldugunu dusundum zaten pacman yeni pacman versiyonu oldugunu soyluyordu ve upgrade et dedigimde pacman < 4.1 gibi bir hata veriyordu. Dolayisiyla problemin pacman'da oldugunu dusundum ve pacman'i yuklemeye calistim, pacman openssl ve libarchive'in en son surumlerini root a indirim untar ettim. Suan pacman'in hicbir islevi kalmadi, surekli asagidaki hatayi veriyor.



pacman: error while loading shared libraries: libalpm.so.8: cannot open shared object file: No such file or directory



Bu problemi cozmeme yardimci olabilecek birisi var mi yoksa yeniden arch linux kurmami mi onerirsiniz?



Simdiden okuyan herkeze tesekkurler..
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı curelight

  • İleti: 127
Re: Pacman'i bozdum, yeniden kuramiyorum.
« Yanıtla #1 : 28 Temmuz 2013 - 22:35:22 »
Merhabalar, sizde bulunamayan libalpm.so.8 dosyasını kendi sistemimde arattığımda /usr/lib altında buldum.Şu şekilde bir aratın,
Kod: [Seç]
#find / -name libalpm.so.8
 eğer bulunamıyorsa pyalpm paketini kurmanız gerekir.Fakat pacman çalışmadığı için kendiniz derlemelisiniz.

http://https://projects.archlinux.org/users/remy/pyalpm.git/  kurduktan sonra  libalpm.so.8 dosyasının /usr/lib altında olduğunu kontrol edin.Çok eğlenceli bir sıkıntı gibi görünüyor, kolay gelsin.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı mnyak

  • Newbie
  • *
  • İleti: 3
Re: Pacman'i bozdum, yeniden kuramiyorum.
« Yanıtla #2 : 29 Temmuz 2013 - 00:24:07 »
Yorum icin tesekkurler, soylediginiz cozumle ugrasirken 64 bit yerine 32 bit'lik pacman'i yukledigimi fark ettim ve duzelttim. Simdilik cok duzgun olmasa da pacman calisir durumda...
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »