Gönderen Konu: Archbang cairo-compmgr-git kurulumunda 'valac' hatası  (Okunma sayısı 1380 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı caniko

  • İleti: 29
Merhaba

Aur'dan cairo-compmgr-git kurmak istediğimde vala-git paketini de kurmak istiyor.Ancak vala-git kurulamıyor.
Kod: [Seç]
[caniko@archacer ~]$ packer -S cairo-compmgr-git

Aur Targets    (2): vala-git cairo-compmgr-git

Proceed with installation? [Y/n]

Edit vala-git PKGBUILD with $EDITOR? [Y/n] n
==> Son git sürümü belirleniyor...
  -> Değişiklik numarası olarak 20120403 bulundu
==> vala-git 20120403-1 (Sal Nis  3 22:18:46 EEST 2012) paketi oluşturuluyor
==> Bağımlılıklar denetleniyor...
==> Derleme bağımlılıkları denetleniyor...
==> Kaynak kodları alınıyor...
==> Kaynak Kodları Açılıyor...
==> Mevcut pkg/ dizini kaldırılıyor ...
==> build() işlemine başlanıyor...
==> Connecting to GIT server....
Already up-to-date.
==> The local files are updated.
==> GIT checkout done or server timeout
==> Starting build...
Cloning into '/tmp/packerbuild-1000/vala-git/vala-git/src/vala-build'...
done.
./autogen.sh: line 10: valac: komut yok
**Error**: You must have valac >= 0.12.0 installed
  to build vala. Download the appropriate package
  from your distribution or get the source tarball at
  http://download.gnome.org/sources/vala/
==> HATA: build() içinde bir hata oluştu.
    Çıkılıyor...
The build failed.
Dependencies for `cairo-compmgr-git' are not met, not building...
[caniko@archacer ~]$

Depolardan valac diye bir şey var mı diye arattığımda
Kod: [Seç]
packer -Ss valac
aur/vala057 0.5.7-1 (6)
    Older version of valac (suitable for compiling media-applet)
[caniko@archacer ~]$ pacman -Ss valac
[caniko@archacer ~]$

vala057 paketini kurdum işe yaramadı yine ilk kod kutusundaki hatayı alıyorum.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: decent »
https://linuxcounter.net/cert/483272.png" alt="" class="bbc_img" />

Çevrimdışı decent

  • Administrator
  • *****
  • İleti: 1.091
    • ARCHER KIM
  • Dağıtım: Arch Linux <:> Ubuntu
  • Sürüm: *
  • Ekran Kartı: Nvidia / ATI
RE: cairo-compmgr-git kurulumunda 'valac' hatası
« Yanıtla #1 : 03 Nisan 2012 - 22:55:38 »
En başta şu paketi yüklemeyi deneyiniz..

https://aur.archlinux.org/packages.php?ID=31429


Kod: [Seç]
yaourt -S vala-git
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Anonymous »

Çevrimdışı caniko

  • İleti: 29
Cvp: cairo-compmgr-git kurulumunda 'valac' hatası
« Yanıtla #2 : 03 Nisan 2012 - 23:11:47 »
@decent hata vala-git kurulumunda çıkıyor.İlk mesajımda belirttiğim gibi.cairo-compmgr-git'e sıra gelmiyor vala-git yüzünden.Aur vala-git sayfasında birisi benim gibi yorum yazmış bügün.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Anonymous »
https://linuxcounter.net/cert/483272.png" alt="" class="bbc_img" />

Çevrimdışı tarakbumba

  • İleti: 252
RE: cairo-compmgr-git kurulumunda 'valac' hatası
« Yanıtla #3 : 03 Nisan 2012 - 23:35:48 »
vala-devel paketini resmi depolardan kurunuz öncelikle.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Anonymous »

Çevrimdışı caniko

  • İleti: 29
Cvp: cairo-compmgr-git kurulumunda 'valac' hatası
« Yanıtla #4 : 04 Nisan 2012 - 00:04:14 »
@tarakumba resmi depolarda o paket bulunmadı. Aur depodan vala-devel paketini kurdum.

vala-git kuruluma geçtiğimde oldukça bol satırlı arraylist hata çıktısı verdi.Hepsini değilde artık son satırları ekledim kutuya.
Kod: [Seç]
rraylist.c:963:9: error: expected ';' before 'TERATOR_GET_PRIVATE'
arraylist.c:963:9: error: stray '304' in program
arraylist.c:963:9: error: stray '260' in program
arraylist.c:963:9: error: stray '304' in program
arraylist.c:963:9: error: stray '260' in program
arraylist.c:963:9: error: stray '304' in program
arraylist.c:963:9: error: stray '260' in program
arraylist.c:965:2: error: stray '304' in program
arraylist.c:965:2: error: stray '260' in program
arraylist.c:965:2: error: called object 'TERATOR_GET_CLASS(obj)' is not a function
arraylist.c:965:2: error: stray '304' in program
arraylist.c:965:2: error: stray '260' in program
arraylist.c:965:9: error: expected ';' before 'TERABLE_CLASS'
arraylist.c: In function 'vala_array_list_get_type':
arraylist.c:977:3: error: stray '304' in program
arraylist.c:977:3: error: stray '260' in program
arraylist.c:977:3: error: stray '304' in program
arraylist.c:977:3: error: stray '260' in program
arraylist.c:977:66: error: expected ')' before 'ST'
arraylist.c:977:66: error: too few arguments to function 'g_type_register_static'
/usr/include/glib-2.0/gobject/gtype.h:1220:7: note: declared here
make[3]: *** [arraylist.lo] Hata 1
make[3]: `/tmp/packerbuild-1000/vala-git/vala-git/src/vala-build/gee' dizininden çıkılıyor
make[2]: *** [all] Hata 2
make[2]: `/tmp/packerbuild-1000/vala-git/vala-git/src/vala-build/gee' dizininden çıkılıyor
make[1]: *** [all-recursive] Hata 1
make[1]: `/tmp/packerbuild-1000/vala-git/vala-git/src/vala-build' dizininden çıkılıyor
make: *** [all] Hata 2
==> HATA: build() içinde bir hata oluştu.
    Çıkılıyor...
The build failed.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Anonymous »
https://linuxcounter.net/cert/483272.png" alt="" class="bbc_img" />

Çevrimdışı tarakbumba

  • İleti: 252
RE: cairo-compmgr-git kurulumunda 'valac' hatası
« Yanıtla #5 : 04 Nisan 2012 - 00:37:10 »
Packer kullandığım için yanlış görmüşüm. Açıkçası sorunun nereden kaynaklandığını bilemem. Vala-devel "valac" sunuyor ki derlemeye geçilmiş. Ancak sonuçta bunun bir "geliştirme ortamı yansısı" (git) olduğu düşünülürse sorunların yaşanması çok kuvvetli bir ihtimal.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Anonymous »

Çevrimdışı caniko

  • İleti: 29
RE: cairo-compmgr-git kurulumunda 'valac' hatası
« Yanıtla #6 : 04 Nisan 2012 - 01:03:53 »
cairo-compmgr'yi Aur üzerinden iki ay önce başka Arch+Openbox üzerinde kurup çalıştırmıştım.Hatırlıyorum.

Zamana bırakakırız bizde.

Teşekkürler.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Anonymous »
https://linuxcounter.net/cert/483272.png" alt="" class="bbc_img" />

Çevrimdışı hsngrms

  • İleti: 1.707
RE: cairo-compmgr-git kurulumunda 'valac' hatası
« Yanıtla #7 : 04 Nisan 2012 - 23:23:24 »
Çıktılara bakılırsa vala-git kurmadan önce cairo-compmgr-git kurması lazım ama senin dediğine göre cairo için vala bağımlılığı var. Kısır döngüye girmiş resmen.



Extra deposundan kurulan vala paketi işini görmüyor mu?
Kod: [Seç]
# pacman -S vala
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Anonymous »