*
Arch Linux Türkiye Forum


Hoşgeldiniz Ziyaretçi. Lütfen giriş yapın veya kayıt olun.

Kullanıcı adınızı, şifrenizi ve aktif kalma süresini giriniz

Pacman güncellemesi ve Sistem güncellemesi 2277

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

İleti: 82
Pacman güncellemesi ve Sistem güncellemesi
« : 04 Ocak 2015 - 14:51:04 »
Arkadaşlar pacman sürümünü 4.2.x güncellemesi gelenlerde bir güncelleme engeli karşınıza çıkabilir. Unstable depoları kullananlar rastlamıştır muhtemelen. Arch ve bu tabanı kullanan dağıtımlar için de geçerlidir.



Şuna benzer bir uyarı çıktısı görebilirsiniz:
Kod: [Seç]
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<4.2
:: pkgbrowser: requires pacman<4.2"




Şöyle bir yol izleyiniz:
Kod: [Seç]

sudo pacman -R package-query
sudo pacman -S pacman --force
sudo pacman -Syyu
sudo pacman -S package-query
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Administrator İleti: 2.228 *****
Re: Pacman güncellemesi ve Sistem güncellemesi
« Yanıtla #1 : 11 Ocak 2015 - 10:21:44 »
Kod: [Seç]
#pacman -Sdd pacman
#pacman-db-upgrade
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

İleti: 1.707
Re: Pacman güncellemesi ve Sistem güncellemesi
« Yanıtla #2 : 13 Ocak 2015 - 20:32:02 »
Kod: [Seç]
# pacman-db-upgrade

Yukarıdaki komut tek başına yeterli olmalı, ben o şekilde uyguladım sıkıntı çıkmadı. Sonrasında normal güncelleme yapabiliyorsunuz.
Kod: [Seç]
# pacman -Syu
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

İleti: 40
Re: Pacman güncellemesi ve Sistem güncellemesi
« Yanıtla #3 : 15 Ocak 2015 - 14:44:48 »
Alıntı yapılan: "hsngrms"
Kod: [Seç]
# pacman-db-upgrade

Yukarıdaki komut tek başına yeterli olmalı, ben o şekilde uyguladım sıkıntı çıkmadı. Sonrasında normal güncelleme yapabiliyorsunuz.
Kod: [Seç]
# pacman -Syu



Kod: [Seç]
# pacman-db-upgrade
bende de yeterli oldu.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

>_Root