Gönderen Konu: ATI 5xxx ve sonrası kartlar için Catalyst-test kurulumu  (Okunma sayısı 4008 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı iceboy

  • İleti: 68
Bu anlatım 5xxx ve sonrası karlar için geçerlidir, 1xxx,2xxx,3xxx serisi kartlar desteklenmemektedir.



Bildiğiniz veya şu anda öğrenmekte olduğunuz üzere
Kod: [Seç]
catalyst-test
hem yeni ATI kartlarda daha stabil ve sorunsuz çalışmakta,hemde
Kod: [Seç]
Catalyst
driverinin getirdiği bazı xorg uyumsuzlukları burada yaşanmamaktadır.



Ayırca yukarıdaki paketlerin getirdiği sorunlar için
Kod: [Seç]
/etc/default/grub
içerisine "nomodeset" , "radeon.runpm=0" gibi parametreler eklediysek bunları siliyoruz.



Öncelikle
Kod: [Seç]
[b]xf86-video-ati ati-dri glamor-egl[/b]
gibi açık sürücü ve bağımlılıklarını kurduysanız bunları kaldırıyoruz.Burada eğer kaldırmayı unuttuğunuz olursa zaten yaourt ile catalyst-test kurarken çakışmayı algılayacaktır ve size soracaktır kaldırılsın mı diye.Çakışan paketlere "y" diyerek geçerseniz kaldıracaktır.



Kuruluma başlıyoruz ; (AUR Kurduğunuzu varsayarak)


Kod: [Seç]
yaourt -S catalyst-test
ile kurulumun ilk adımını başlatıyoruz.Burada dikkat edilmesi gereken bu komut normal kullanıcı olarak verilmelidir,root olarak değil !



yaourt ile catalyst-test kurulumu bittikten sonra aşağıdaki kodları sırası ile ve root olarak vereceğiz,satır başlarındanki sudo lardan da anlayabilirsiniz olayı.


Kod: [Seç]
sudo systemctl enable atieventsd
sudo systemctl start atieventsd
sudo systemctl enable catalyst-hook
sudo systemctl start catalyst-hook




yukarıdaki kodları sırasi ile ve tek tek yürüttükten sonra


Kod: [Seç]
sudo aticonfig --initial
komutunu veriyoruz.



Sonra eğer syslinux kullanıyorsanız ;



/boot/syslinux/syslinux.cfg dosyasını düzenleyeceksiniz ve APPEND Satırına nomodeset ekleyeceğiz ve şöyle görünecek


Kod: [Seç]
APPEND root=/dev/sda[x] rw nomodeset


Eğer grub kullanıyorsanız ;




Kod: [Seç]
/etc/default/grub
dosyasını düzenleyeceğiz,bu dosyanın içerisine
Kod: [Seç]
GRUB_CMDLINE_LINUX=
satırının sonuna "nomodeset" ekleyeceğiz ve satırın görünümü böyle olacak


Kod: [Seç]
GRUB_CMDLINE_LINUX="nomodeset"


ve bu düzenlemeyi yaptıktan sonra yaptığımız değişikliklerin kaydedilmesi için aşağıdaki komudu yürütüyoruz ;


Kod: [Seç]
sudo grub-mkconfig -o /boot/grub/grub.cfg


Ayrıca arayüzün sorunsuz çalışabilmesi için gerekli olan ;


Kod: [Seç]
pacman -S acpid qt4
komutu ile acpid ve qt4 paketlerini kuruyoruz



Son olarak
Kod: [Seç]
sudo reboot
ile sistemi yeniden başlatıyoruz,ve bu kadar !



Saygılarımla ve yararlı olması dileğiyle.



Dipçe] Bu anlatım http://bbs.archbang.org/viewtopic.php?id=4630 daki konunun Türkçeye çevrilmiş ve sadeleştirilmiş halidir.İngilizcesi iyi olan arkadaşlar herhangi bir sorun yaşadığında veyahut benim anlatımımı yetersiz bulduğunda linke başvurabilir.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı iceboy

  • İleti: 68
Re: ATI 5xxx ve sonrası kartlar için Catalyst-test kurulumu
« Yanıtla #1 : 07 Kasım 2014 - 01:12:53 »
Nomodeset kısmı artık gereksizdir ve yapılmasına gerek yoktur.



Grub dosyamıza "nomodeset" parametresini eklediğimiz adımları atlayacak kurulumu gerçekleştiriniz.



Bir türlü konuyu değiştir butonunu bulamadığım yada yetkim olmadığı için konuyu düzenleyemiyorum o yüzden buraya yazdım.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı karasu

  • Newbie
  • *
  • İleti: 267
Re: ATI 5xxx ve sonrası kartlar için Catalyst-test kurulumu
« Yanıtla #2 : 07 Kasım 2014 - 12:16:24 »
ben yigenlerime lenova g510 notebook aldim. linux kurulumunda amd ekran kartini goremedigim icin win7 kurdum. Ama olay farkliymis artik cift ekran karti olan notebooklar islem gerektiren uygulamalarda harici ekrankartina yoneliyormus. windows driverini kurcalarken bunu ogrendim.



böyle bir notebook'a amd ve intel ekran kartlarını nasıl kurabilirim. eğer yapabilirsem onlarıda linux'a geçiricem. (zorla :D)
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı iceboy

  • İleti: 68
Re: ATI 5xxx ve sonrası kartlar için Catalyst-test kurulumu
« Yanıtla #3 : 07 Kasım 2014 - 19:54:51 »
Alıntı yapılan: "karasu"
ben yigenlerime lenova g510 notebook aldim. linux kurulumunda amd ekran kartini goremedigim icin win7 kurdum. Ama olay farkliymis artik cift ekran karti olan notebooklar islem gerektiren uygulamalarda harici ekrankartina yoneliyormus. windows driverini kurcalarken bunu ogrendim.



böyle bir notebook'a amd ve intel ekran kartlarını nasıl kurabilirim. eğer yapabilirsem onlarıda linux'a geçiricem. (zorla :D)


Kurulum tabiki mümkün.



Benim laptopta da 2 tane ekran kartı var,birisi 6650G (işlemcinin üzerinde sizdeki intel gibi,yalnız benim iki kartta amd) diğeri ise harici PCI 7670M Ekran kartı.



İnternette birçok kaynak mevcut hocam,ama bulamazsanız yardım ederiz elbet
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı cumali

  • Administrator
  • *****
  • İleti: 2.228
Re: ATI 5xxx ve sonrası kartlar için Catalyst-test kurulumu
« Yanıtla #4 : 07 Kasım 2014 - 21:16:29 »
Alıntı yapılan: "iceboy"

Bir türlü konuyu değiştir butonunu bulamadığım yada yetkim olmadığı için konuyu düzenleyemiyorum o yüzden buraya yazdım.


Düzeltilmesi yada silinmesini istedigin satırları alıntı yaparak mesaja yazın. Gerekli düzenlemeyi yaparım. Bu arada katkıların için teşekkür ederim.



Konuyu tam incelemedim ama benzer bir konu evolutionlinux.com forumunda işlenmiş. Belki bir arkadaşın işine yarayabilir. http://www.evolutionlinux.com/forums/viewtopic.php?f=12&t=321#p2092" class="bbc_link" target="_blank">http://http://www.evolutionlinux.com/forums/viewtopic.php?f=12&t=321#p2092
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı iceboy

  • İleti: 68
Re: ATI 5xxx ve sonrası kartlar için Catalyst-test kurulumu
« Yanıtla #5 : 07 Kasım 2014 - 21:39:53 »
Alıntı yapılan: "cumali"
Alıntı yapılan: "iceboy"

Bir türlü konuyu değiştir butonunu bulamadığım yada yetkim olmadığı için konuyu düzenleyemiyorum o yüzden buraya yazdım.


Düzeltilmesi yada silinmesini istedigin satırları alıntı yaparak mesaja yazın. Gerekli düzenlemeyi yaparım. Bu arada katkıların için teşekkür ederim.



Konuyu tam incelemedim ama benzer bir konu evolutionlinux.com forumunda işlenmiş. Belki bir arkadaşın işine yarayabilir. http://www.evolutionlinux.com/forums/viewtopic.php?f=12&t=321#p2092" class="bbc_link" target="_blank">http://http://www.evolutionlinux.com/forums/viewtopic.php?f=12&t=321#p2092


Evolution linux forumunda da eklemişler "nomodeset" i.



Kaldırsak mı kalsamı bilemedim şimdi,benim kartta kaldırmayınca "error" veriyor fakat çalışmaya engel olmuyor,ben sırf başlangıçta hata yazısını görmemek için kaldırdım.



Kalsın şimdilik,ileride kesin bilgiye ulaşırsak düzenleriz.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı iceboy

  • İleti: 68
Re: ATI 5xxx ve sonrası kartlar için Catalyst-test kurulumu
« Yanıtla #6 : 08 Mart 2015 - 22:48:55 »
Aynı yöntemle şu an kurulum yapılamıyor.


Kod: [Seç]
error: target not found: xorg-server<1.17.0


Hatası ile karşılaşıyorsunuz.


Kod: [Seç]
xorg-server
güncellenmiş versionu 1.17 ve sistemde kutulu.



Ama
Kod: [Seç]
yaourt -S catalyst-test
dediğinizde depoda 1.16 versionunu arıyor ve bulamıyor çünki xorg server güncellenmiş 1.17 olmuş.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı iceboy

  • İleti: 68
Re: ATI 5xxx ve sonrası kartlar için Catalyst-test kurulumu
« Yanıtla #7 : 09 Mart 2015 - 16:45:03 »
Ben kurulumu başardım fakat çok uğraştırdı 2 saat araştırma yapıp 3 farklı xorg-server versionu ve belkide 10 tane key girmem gerekti.



Konuyu editleme yetkim olmadığından anlatım yapamıyorum,yalnız yapmanız gereken varsa orta seviye bir ingilizce ile aldığınız hataları googleye yazıp bir linkten diğerine koşturmak.



Yoksa ise yapacağınız şey pacman.conf dosyanıza en üst satıra
Kod: [Seç]
xorg-server 1.15
versionunu barındıran kaynağı eklemek.



Daha sonra key hatası alacaksınız,bu key hatasını https://wiki.archlinux.org/index.php/User:Vi0L0 bu linkteki 2 kodu yürütüp aşacaksınız.


Kod: [Seç]
Catalyst-test
sistemi bozacak olan bir dosyayı kaldırmanızı istiyor ve kaldırırsanız sisteminiz zarar görecek.



Bu yüzden ya
Kod: [Seç]
catalyst
kurulumu yapacaksınız yada yeni
Kod: [Seç]
xorg 1.17
versionu destekleyen sürücü bekleyeceksiniz.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı eronis

  • İleti: 61
Re: ATI 5xxx ve sonrası kartlar için Catalyst-test kurulumu
« Yanıtla #8 : 16 Eylül 2015 - 12:34:10 »
Kardeşim kusura bakma ama o kadar karışık yazmışsın ki "nomodeset" komutunu sadece rehberini okurken 3 kez yazıp sildim. Biraz düzenleme şart. Bunu seni eleştirmek için söylemiyorum ama böyle çok zaman kaybettiriyor, zaten kafa karıştıran bir konu daha fazla kafa karıştırıyor. Öyle olunca da konu faydalı olmaktan çıkıyor.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı decent

  • Administrator
  • *****
  • İleti: 1.092
    • ARCHER KIM
  • Dağıtım: Arch Linux <:> Ubuntu
  • Sürüm: *
  • Ekran Kartı: Nvidia / ATI
Re: ATI 5xxx ve sonrası kartlar için Catalyst-test kurulumu
« Yanıtla #9 : 16 Eylül 2015 - 22:12:37 »
Merhaba [profile]eronis[/profile],

ATI konusu Arch Linux tarafında aralıklarla sıkıntı oluşturabiliyor.

Dolayısıyla wiki kaynağını takip ederek hatta LTS çekirdek ile ve xorg güncellemesi almaksızın yola devam etmek gerekiyor.
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »

Çevrimdışı eronis

  • İleti: 61
Re: ATI 5xxx ve sonrası kartlar için Catalyst-test kurulumu
« Yanıtla #10 : 17 Eylül 2015 - 21:25:22 »
Alıntı

Sorunlu olan Amd/Ati değilde , Catalyst diye küçük bir düzeltme yapalım mı. :) Açık kaynak sürücülerin bu boyutta işlem ve sorunu yok gibi sanki.

Open Source Driver = Kararlılık ve Güvenilirlik (Güvenlik değil, Güvenilirlik)

Sahipli sürücü = Performans ve Verimlilik
« Son Düzenleme: 01 Ocak 1970 - 02:00:00 Gönderen: Guest »