Arch Linux Türkiye Forum

ARCH LINUX YARDIM VE DESTEK => Çekirdek, Donanım => Konuyu başlatan: doctur - 02 Nisan 2012 - 21:33:03

Başlık: Bilgisayarın kapatıldıktan sonra yeniden açılması sorunu
Gönderen: doctur - 02 Nisan 2012 - 21:33:03
Prize takılı iken notebook'umu kullanıcı menüsünden kapattım.Dakikalarca(~30 dk)  bekledim.Hiçbir değişiklik olmadı.Fakat fişi prizden çekip batarya moduna geçince bilgisayar 15 saniye içinde kendiliğinden yeniden açılmaya başladı.



Bu defa batarya modunda açıp yeniden kapattım.15 saniye içinde yeniden açılmaya başladı.



Söz konusu her iki durumda notebooku kapadıktan sonra kapağını kapatmam sonucu değiştirmedi.Kapak kapalı iken de yeniden açılıyor.



Özetle batarya modunda bilgisayarımı kapatamıyorum.



Ancak bilgisayarımda yüklü olan diğer bir dağıtıma geçerek kapatabiliyorum.
Başlık: RE: Bilgisayarın kapatıldıktan sonra yeniden açılması sorunu
Gönderen: cumali - 02 Nisan 2012 - 22:15:23
Bahsettigin sorun öteden beri var olan bir sorun mu? Yoksa yeni oluşan bir sorun mu? Mesela bu sorun oluşmadan ne tür bir uygulama yaptınız da bu sorun ortaya çıktı? Anlattığına bakılırsa donanımsal bir sorun degil.
Başlık: Cvp: Bilgisayarın kapatıldıktan sonra yeniden açılması sorunu
Gönderen: doctur - 02 Nisan 2012 - 22:32:55
Ne zaman oluştuğu konusunda emin değilim.Bilgisayarımda bir çok dağıtım yüklü.Böyle bir şey şimdiye kadar hiç başıma gelmediği için geçtiğimiz günlerde bilgisayarımı 2 kez kapattığım halde açık bulunca herhalde benden sonra hanım kullandı ve kapatamadı diye yorum yapıp önemsemedim.Buğün yine açık bulunca hanımın bilgisayarıma hiç dokunmadığını öğrenince test etmeye başladım.Yukarki sonuçları buldum ve sizlerle paylaşmaya karar verdim.Doğru dürüst bir şey yüklemedim.Sadece yaourt paketini kurmuştum.Şimdilik sürekli wikiden okuyup öğrenme aşamasındayım.Saygılar.
Başlık: RE: Bilgisayarın kapatıldıktan sonra yeniden açılması sorunu
Gönderen: decent - 02 Nisan 2012 - 22:45:00
Bios markası ve sürümü nedir ?

Bios ayarlarından ilgili maddelere baktınız mı ?
Başlık: Cvp: Bilgisayarın kapatıldıktan sonra yeniden açılması sorunu
Gönderen: if* - 02 Nisan 2012 - 23:33:11
@doctur, güç yönetimi için herhangi bir uygulama kullanıyor musunuz? Ayarları nedir? Hangi masaüstünü kullanıyorsunuz? Hangi giriş ekranı yöneticisini kullanıyorsunuz? Kapatılırken nerede takıldığını öğrenmemiz iyi olur. Fişe takılıyken kapatınız ve takıldığı zaman sanal terminale geçip
Kod: [Seç]
dmesg | grep ACPI > dmesg.txt
komutunu verip çıktıyı buraya aktarır mısınız?
Başlık: Cvp: Bilgisayarın kapatıldıktan sonra yeniden açılması sorunu
Gönderen: doctur - 03 Nisan 2012 - 20:21:11
Kod: [Seç]
$ dmesg | grep ACPI
[    0.000000]  BIOS-e820: 0000000077e70000 - 0000000077e82000 (ACPI data)
[    0.000000]  BIOS-e820: 0000000077e82000 - 0000000077e84000 (ACPI NVS)
[    0.000000] ACPI: RSDP 00000000000f82f0 00024 (v02 TOSINV)
[    0.000000] ACPI: XSDT 0000000077e7a581 00054 (v01 TOSINV TOSINV00 06040000  INV 00000000)
[    0.000000] ACPI: FACP 0000000077e81a4a 000F4 (v03 ATI    Herring  06040000 ATI  000F4240)
[    0.000000] ACPI: DSDT 0000000077e7a5d5 07475 (v01 TOSINV    SB600 06040000 MSFT 0100000E)
[    0.000000] ACPI: FACS 0000000077e83fc0 00040
[    0.000000] ACPI: SSDT 0000000077e81bb2 00210 (v01 PTLTD  POWERNOW 06040000  LTP 00000001)
[    0.000000] ACPI: APIC 0000000077e81dc2 00054 (v01 TOSINV ? APIC   06040000  INV 00000000)
[    0.000000] ACPI: SLIC 0000000077e81e16 00176 (v01 TOSINV TOSINV00 06040000  INV 00000000)
[    0.000000] ACPI: MCFG 0000000077e81f8c 0003C (v01 TOSINV   MCFG   06040000  INV 00000000)
[    0.000000] ACPI: HPET 0000000077e81fc8 00038 (v01 PTLTD  HPETTBL  06040000  LTP 00000001)
[    0.000000] ACPI: Local APIC address 0xfee00000
[    0.000000] ACPI: PM-Timer IO Port: 0x8008
[    0.000000] ACPI: Local APIC address 0xfee00000
[    0.000000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
[    0.000000] ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] enabled)
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
[    0.000000] ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
[    0.000000] ACPI: IRQ9 used by override.
[    0.000000] Using ACPI (MADT) for SMP configuration information
[    0.000000] ACPI: HPET id: 0x43538301 base: 0xfed00000
[    0.007795] ACPI: Core revision 20110623
[    0.007939] ACPI: Forced DSDT copy: length 0x07475 copied locally, original unmapped
[    0.201995] PM: Registering ACPI NVS region at 77e82000 (8192 bytes)
[    0.201995] ACPI: bus type pci registered
[    0.207113] ACPI: Added _OSI(Module Device)
[    0.207113] ACPI: Added _OSI(Processor Device)
[    0.207113] ACPI: Added _OSI(3.0 _SCP Extensions)
[    0.207113] ACPI: Added _OSI(Processor Aggregator Device)
[    0.207905] ACPI: EC: Look up EC in DSDT
[    0.210640] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[    0.403340] ACPI: Interpreter enabled
[    0.403345] ACPI: (supports S0 S3 S4 S5)
[    0.403366] ACPI: Using IOAPIC for interrupt routing
[    0.450190] ACPI: Power Resource [PFA1] (off)
[    0.450399] ACPI: EC: GPE = 0x7, I/O: command/status = 0x66, data = 0x62
[    0.450553] ACPI: No dock devices found.
[    0.450561] PCI: Ignoring host bridge windows from ACPI; if necessary, use "pci=use_crs" and report a bug
[    0.451386] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-ff])
[    0.457377] ACPI: PCI Interrupt Routing Table [_SB_.PCI0._PRT]
[    0.457467] ACPI: PCI Interrupt Routing Table [_SB_.PCI0.PB4_._PRT]
[    0.457514] ACPI: PCI Interrupt Routing Table [_SB_.PCI0.PB5_._PRT]
[    0.457554] ACPI: PCI Interrupt Routing Table [_SB_.PCI0.PB6_._PRT]
[    0.457598] ACPI: PCI Interrupt Routing Table [_SB_.PCI0.BB4_._PRT]
[    0.457643] ACPI: PCI Interrupt Routing Table [_SB_.PCI0.BB5_._PRT]
[    0.457725] ACPI: PCI Interrupt Routing Table [_SB_.PCI0.P2P_._PRT]
[    0.457759] ACPI: PCI Interrupt Routing Table [_SB_.PCI0.AGP_._PRT]
[    0.457795]  pci0000:00: Requesting ACPI _OSC control (0x1d)
[    0.457800]  pci0000:00: ACPI _OSC request failed (AE_NOT_FOUND), returned control mask: 0x1d
[    0.457803] ACPI _OSC control for PCIe not granted, disabling ASPM
[    0.462513] ACPI: PCI Interrupt Link [LNKA] (IRQs 10 11) *0, disabled.
[    0.462563] ACPI: PCI Interrupt Link [LNKB] (IRQs 10 11) *0, disabled.
[    0.462615] ACPI: PCI Interrupt Link [LNKC] (IRQs 10 11) *0, disabled.
[    0.462661] ACPI: PCI Interrupt Link [LNKD] (IRQs 10 11) *0, disabled.
[    0.462709] ACPI: PCI Interrupt Link [LNKE] (IRQs 10 11) *0, disabled.
[    0.462756] ACPI: PCI Interrupt Link [LNKF] (IRQs 10 11) *0, disabled.
[    0.462803] ACPI: PCI Interrupt Link [LNKG] (IRQs 10 11) *0, disabled.
[    0.462850] ACPI: PCI Interrupt Link [LNKH] (IRQs 10 11) *0, disabled.
[    0.462961] PCI: Using ACPI for IRQ routing
[    0.472206] pnp: PnP ACPI init
[    0.472233] ACPI: bus type pnp registered
[    0.474117] pnp 00:00: Plug and Play ACPI device, IDs PNP0a08 PNP0a03 (active)
[    0.474267] system 00:01: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.474753] pnp 00:02: Plug and Play ACPI device, IDs PNP0200 (active)
[    0.474824] pnp 00:03: Plug and Play ACPI device, IDs PNP0c04 (active)
[    0.474894] pnp 00:04: Plug and Play ACPI device, IDs PNP0b00 (active)
[    0.474943] pnp 00:05: Plug and Play ACPI device, IDs PNP0800 (active)
[    0.475010] pnp 00:06: Plug and Play ACPI device, IDs PNP0303 (active)
[    0.475082] pnp 00:07: Plug and Play ACPI device, IDs SYN1909 SYN1900 SYN0002 PNP0f13 (active)
[    0.475353] system 00:08: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.475499] system 00:09: Plug and Play ACPI device, IDs PNP0c01 (active)
[    0.475649] pnp 00:0a: Plug and Play ACPI device, IDs PNP0103 (active)
[    0.477090] pnp: PnP ACPI: found 11 devices
[    0.477092] ACPI: ACPI bus type pnp unregistered
[    0.490326] pci 0000:00:13.5: power state changed by ACPI to D0
[    0.490336] pci 0000:00:13.5: power state changed by ACPI to D0
[    0.751256] ehci_hcd 0000:00:13.5: power state changed by ACPI to D0
[    0.751264] ehci_hcd 0000:00:13.5: power state changed by ACPI to D0
[    6.014432] ACPI: Power Button [PWRB]
[    6.015324] ACPI: Lid Switch [LID]
[    6.015395] ACPI: Power Button [PWRF]
[    6.024414] toshiba_bluetooth: Detected Toshiba ACPI Bluetooth device - installing RFKill handler
[    6.082162] ACPI: Battery Slot [BAT0] (battery present)
[    6.092085] ACPI: AC Adapter [ADP0] (on-line)
[    6.097243] ACPI: Thermal Zone [TZCR] (59 C)
[    6.097335] ACPI: Fan [FAN1] (off)
[    6.099560] ACPI: Video Device [VGA] (multi-head: yes  rom: no  post: no)
[    6.130737] ACPI: processor limited to max C-state 1
[    6.547346] toshiba_acpi: Toshiba Laptop ACPI Extras version 0.19
[    7.438123] radeon 0000:01:05.0: power state changed by ACPI to D0
[    7.438130] radeon 0000:01:05.0: power state changed by ACPI to D0


Arch 64 bit Gnome kullanıyorum.Güç yönetimiyle ilgili yeni bir şey yüklemedim.Sadece gnome ve gnome-extra ile ne yüklendiyse o var.Üst panelde standart güç ayarları var.
Başlık: RE: Bilgisayarın kapatıldıktan sonra yeniden açılması sorunu
Gönderen: if* - 03 Nisan 2012 - 22:12:23
@doctur, iki ekran kartı mı var bilgisayarda?
Başlık: Cvp: Bilgisayarın kapatıldıktan sonra yeniden açılması sorunu
Gönderen: doctur - 03 Nisan 2012 - 22:33:51
@if* tek ekran kartı var.



Şimdi daha değişik ve ilginç bir bulgu daha tespit ettim.Şöyleki;

Bilgisayarımı Arch linuxdayken kapatınca biosumun saat ayarı değişiyor.Örneğin 1-3 saat geri gidiyor.Bios saatini güncelleyip ayarları kaydetip arch linuxu açıyorum.Şimdi arch linuxdayım.Yeniden kapatıyorum.Fişi çekip pil moduna geçiyorum.Bilgisayarım yeniden açılmıyor.Sorun çözüldü gibi görünüyor.Fakat bilgisayarımı arch linuxdayken kapattığım için biosumun saat ayarı yeniden bozulmuş oluyor.Şimdi bilgisayarımı yeniden arch linux ile açıyorum.Yeniden kapatıyorum.Fişi çekip pil moduna geçiyorum.30 saniye içinde bilgisayarım kendiliğinden yeniden açılıyor.
Başlık: RE: Bilgisayarın kapatıldıktan sonra yeniden açılması sorunu
Gönderen: if* - 04 Nisan 2012 - 00:07:06
Garip bir durum.
@doctur, başka dağıtım var mı bilgisayarda?
Kod: [Seç]
dmesg
çıktısına bakayım, bir şey yakalayabilirim belki. Çıktı çok uzun olacaktır, pastebin.com sitesine yükleyip bağlantı geçebilirsiniz.
Başlık: Cvp: Cvp: Bilgisayarın kapatıldıktan sonra yeniden açılması sorunu
Gönderen: Aequitas - 04 Nisan 2012 - 13:41:26
Alıntı yapılan: "doctur"

@if* tek ekran kartı var.



Şimdi daha değişik ve ilginç bir bulgu daha tespit ettim.Şöyleki;

Bilgisayarımı Arch linuxdayken kapatınca biosumun saat ayarı değişiyor.Örneğin 1-3 saat geri gidiyor.Bios saatini güncelleyip ayarları kaydetip arch linuxu açıyorum.Şimdi arch linuxdayım.Yeniden kapatıyorum.Fişi çekip pil moduna geçiyorum.Bilgisayarım yeniden açılmıyor.Sorun çözüldü gibi görünüyor.Fakat bilgisayarımı arch linuxdayken kapattığım için biosumun saat ayarı yeniden bozulmuş oluyor.Şimdi bilgisayarımı yeniden arch linux ile açıyorum.Yeniden kapatıyorum.Fişi çekip pil moduna geçiyorum.30 saniye içinde bilgisayarım kendiliğinden yeniden açılıyor.


rc.conf dosyasında zaman ayarı için "UTC" yerine "localtime" yazarsanız bu sorun çözülebilir. Bende de böyle bir sorun vardı, bu şekilde çözmüştüm.
Başlık: Cvp: Bilgisayarın kapatıldıktan sonra yeniden açılması sorunu
Gönderen: doctur - 08 Nisan 2012 - 20:04:42
rc.conf dosyasında zaman ayarı zaten "localtime" idi.Sorunu şimdilik sistemi yeniden yükleyerek çözebildim.İlginiz için teşekkürler.